Bug 1122298 - JDG Enterprise Doc missing JDBC Namespace Configuration
Summary: JDG Enterprise Doc missing JDBC Namespace Configuration
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation
Version: 6.2.1
Hardware: Unspecified
OS: Unspecified
urgent
unspecified
Target Milestone: Post GA
: 6.3.0
Assignee: Rakesh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 21:08 UTC by John Osborne
Modified: 2014-09-15 00:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-15 00:01:44 UTC
Type: Bug


Attachments (Terms of Use)

Description John Osborne 2014-07-22 21:08:39 UTC
The XML for a JDBC Cache Store is its own XML Schema, as referenced in the community doc here:

Search for "multiple XML schemas" http://infinispan.org/docs/6.0.x/user_guide/user_guide.html

This documentation needs to be added to the enterprise documentation.

Without adding the appropriate cache store XML namespace/schema to your cache configuration, you will get XML parse errors.

Comment 2 John Osborne 2014-07-22 23:58:52 UTC
In the 6.2 Admin Guide, Chapter has gives XML configurations that will not work without making the change to include multiple XML Schemas.

For a specific example look at 15.2.2. JdbcStringBasedStore Configuration (Library Mode)

Comment 3 Rakesh 2014-08-22 12:28:14 UTC
The multiple XML schemas seems to be added in JDBC cache store Library configurations and not in server mode configs. The header of server mode configuration remains the same for configs with and without JDBC configured. 

John, am I correct with what I stated above? Also, there is no schemas found in 6.3 related ISPN repo. So I assume that this is not relevant for JDG 6.3. So my 2 queries are:

1. Should the multiple XML schemas be added in server mode configs as well?
2. Should the multiple XML schemas be added in JDG 6.3 docs or only in 6.2?

Comment 7 Rakesh 2014-09-01 12:16:42 UTC
I have resumed office from today. I consulted with Tomas about this and he will provide his findings about adding the XML schemas in 6.3 JDBC configs later today.

Comment 8 Tomas Sykora 2014-09-01 16:27:37 UTC
Hey Bobb,
I've confirmed working configuration for both JDG 6.2 and 6.3.

Into header:

<infinispan
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="urn:infinispan:config:6.0 http://www.infinispan.org/schemas/infinispan-config-6.0.xsd
            urn:infinispan:config:jdbc:6.0 http://www.infinispan.org/schemas/infinispan-cachestore-jdbc-config-6.0.xsd"
        xmlns="urn:infinispan:config:6.0">

And add xmlns="urn:infinispan:config:jdbc:6.0" definition into specific jdbc cache store element -- like this: 

<stringKeyedJdbcStore xmlns="urn:infinispan:config:jdbc:6.0"

fetchPersistentState="false"
​ignoreModifications="false" 
​purgeOnStartup="false"​			      key2StringMapper="org.infinispan.loaders.keymappers.DefaultTwoWayKey2StringMapper">

This configuration works for me with both 6.1.1.ER1-redhat-1 and 6.0.3.Final-redhat-3.

Hope that helps.
Tomas

Comment 12 Rakesh 2014-09-03 17:49:23 UTC
Hey Misha, could you please brew this and push it live?

Comment 13 Misha H. Ali 2014-09-04 04:20:38 UTC
I'll push the 6.2.1 changes now and the 6.3 ones will go out with the async update so we'll close off this bug once both are released.

Comment 16 Misha H. Ali 2014-09-04 09:43:13 UTC
Created ticket.

Comment 17 Misha H. Ali 2014-09-15 00:01:44 UTC
This content is now available on https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Data_Grid/


Note You need to log in before you can comment on or make changes to this bug.