Bug 1122299 - bulk action "unregister content hosts" throws error @search_service search not defined
Summary: bulk action "unregister content hosts" throws error @search_service search no...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 21:12 UTC by Tom McKay
Modified: 2016-04-22 16:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-16 14:03:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6739 None None None 2016-04-22 16:12:20 UTC

Description Tom McKay 2014-07-22 21:12:50 UTC
<pre>RuntimeError: @search_service search not defined
/home/thomasmckay/code/katello/app/controllers/katello/api/v2/api_controller.rb:49:in `item_search'
/home/thomasmckay/code/katello/app/controllers/katello/api/v2/systems_bulk_actions_controller.rb:219:in `find_system_ids_by_search'
/home/thomasmckay/code/katello/app/controllers/katello/api/v2/systems_bulk_actions_controller.rb:198:in `find_systems'
/home/thomasmckay/code/katello/app/controllers/katello/api/v2/systems_bulk_actions_controller.rb:184:in `find_deletable_systems'
/usr/local/rvm/gems/ruby-1.9.3-p448@foreman/gems/activesupport-3.2.18/lib/active_support/callbacks.rb:531:in `block (3 levels) in _run__3767425233859936060__process_action__4323062264504917719__callbacks'
/usr/local/rvm/gems/ruby-1.9.3-p448@foreman/gems/activesupport-3.2.18/lib/active_support/callbacks.rb:215:in `block in _conditional_callback_around_4210'
/usr/local/rvm/gems/ruby-1.9.3-p448@foreman/gems/activesupport-3.2.18/lib/active_support/callbacks.rb:326:in `around'
/usr/local/rvm/gems/ruby-1.9.3-p448@foreman/gems/activesupport-3.2.18/lib/active_support/callbacks.rb:310:in `_callback_around_2911'
/usr/local/rvm/gems/ruby-1.9.3-p448@foreman/gems/activesupport-3.2.18/lib/active_support/callbacks.rb:214:in `_conditional_callback_around_4210'
/usr/local/rvm/gems/ruby-1.9.3-p448@foreman/gems/activesupport-3.2.18/lib/active_support/callbacks.rb:482:in `block (2 levels) in _run__3767425233859936060__process_action__4323062264504917719__callbacks'
/usr/local/rvm/gems/ruby-1.9.3-p448@foreman/gems/activesupport-3.2.18/lib/active_support/callbacks.rb:215:in `block in _conditional_callback_around_4209'
/home/thomasmckay/code/foreman/app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
/usr/local/rvm/gems/ruby-1.9.3-p448@foreman/gems/activesupport-3.2.18/lib/active_support/callbacks.rb:214:in `_conditional_callback_around_4209'
/usr/local/rvm/gems/ruby-1.9.3-p448@foreman/gems/activesupport-3.2.18/lib/active_support/callbacks.rb:415:in `block in _run__3767425233859936060__process_action__4323062264504917719__callbacks'
/usr/local/rvm/gems/ruby-1.9.3-p448@foreman/gems/activesupport-3.2.18/lib/active_support/callbacks.rb:215:in `block in _conditional_callback_around_4208'
/usr/local/rvm/gems/ruby-1.9.3-p448@foreman/gems/activesupport-3.2.18/lib/active_support/callbacks.rb:326:in `around'
</pre>

Comment 1 Tom McKay 2014-07-22 21:12:51 UTC
Created from redmine issue http://projects.theforeman.org/issues/6739

Comment 3 Brad Buckingham 2014-08-06 20:38:18 UTC
I was unable to reproduce this issue upstream.  In addition, discussed it briefly with Tom and he isn't seeing it with Satellite 6 Snap 3 either.  As a result, I am going to close this BZ out.

I did observe a couple of other issues upstream.  Since they are upstream only, they are tracked with http://projects.theforeman.org/issues/6970 .

Comment 4 Chris Pitman 2015-07-14 21:15:22 UTC
We have run into this issue with the 6.0 GA release.

Steps to reproduce:

1. Create 30 Content Hosts named "bbbb01" to "bbbb30"
2. From the Content Hosts page search for "bbbb*"
3. Go to "Bulk Actions"
4. Select all results by clicking the checkbox next to "Name"
5. Do not scroll down!
6. Click "Select All"
7. Click "Unregister Content Hosts"

Note, this does not happen if we do not use "Select All".

Comment 5 Bryan Kearney 2015-07-14 22:01:26 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6739 has been closed

Comment 6 Chris Pitman 2015-07-14 22:07:52 UTC
The upstream bug was closed as "Unable to Reproduce". I have not found any evidence that this issue has actually been fixed.

Comment 7 Bryan Kearney 2015-07-16 14:03:46 UTC
per comment 3, we are seeing this fixed in Satellite 6.1. If you still see the bug in the 6.1 code base, please re-open this and contact me.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.