Bug 112232 - After install, system does not reboot
After install, system does not reboot
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks: 113478
  Show dependency treegraph
 
Reported: 2003-12-16 09:56 EST by Wendy Hung
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 11:09:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wendy Hung 2003-12-16 09:56:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
H010818)

Description of problem:
After the Red Hat 2.1 AS QU3 installation on a Bladecenter was 
completed, the following text was displayed on the screen.
The blade never rebooted on its own after the install.

Ummouting filesystem....
/mnt/runtime done
disabling /dev/loopo
/proc/bus/usb done
/proc done
/dev/pts dome
/mnt/sysimage/boot done
/mnt//sysimage/proc/bus/usb done
/mnt/sysimage done 
/mnt/source

Apparently this occurs while any USB based filesystems are mounted; 
an endless loop waiting for the filesystem to respond to the unmount 
command.  

Unable to reproduce with RHL 9.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install AS 2.1 Update 3 on system using USB CDROM such as 
Bladecenter


Actual Results:  Requires manual hardware reset.

Expected Results:  System reboots.
Comment 1 Jeremy Katz 2003-12-16 16:25:48 EST
At that point, everything looks unmounted -- /mnt/source should be the
last one that gets unmounted.  Did this happen with U2?  What are the
USB filesystems being mounted for?
Comment 2 Wendy Hung 2003-12-16 16:33:54 EST
Yes this was reproduced with U2.  The USB CD-ROM is mounted for the 
installation and does appear to be unmounted.  However, the system 
does not reboot.
Comment 3 Jeremy Katz 2003-12-16 16:36:14 EST
Can you switch ttys at this point?  If so, is there anything odd on
tty4?  Can you get the output of Alt+SysRq+T?
Comment 4 Wendy Hung 2003-12-17 16:54:21 EST
Looks like it's not an anaconda bug since a similar hang can be 
reproduced post-install.

1.  Mount USB CD-ROM
2.  Attempt to reboot by executing init 6
3.  Server will stop at "Unmounting filesystems" message.

Manual reset of the server is required.
Comment 5 Arjan van de Ven 2003-12-18 03:07:09 EST
ok not a regression "just" a normal bug
Comment 6 Wendy Hung 2004-01-07 13:51:50 EST
Has anyone at Red Hat been able to reproduce this on a blade?
I did find a possible workaround:

At the end of the installtion, at the "Finished" screen, I switched 
to tty2 and ran "umount /mnt/source".  I switched back to the GUI 
screen, and clicked "Finished".  System did not reboot and last 
message seen was "Ejecting /tmp/cdrom"

I reinstalled and this time I ran these commands at the "Finished" 
Screen:
umount /mnt/source
rm /tmp/cdrom

System did reboot, but CD was left in the CDROM.
Comment 14 Wendy Hung 2004-07-19 11:09:14 EDT
fixed in u5 beta.

Note You need to log in before you can comment on or make changes to this bug.