Bug 112237 - cgi/pl scripts fail after upgrade
cgi/pl scripts fail after upgrade
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-16 10:57 EST by Alex Weeks
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-19 10:03:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Weeks 2003-12-16 10:57:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
After installing perl.5.8.0-88.3 cgi and pl scripts will no longer
work in Apache.

Prior to this release it worked.  I have read in the news groups about
this.  There is also bug 90079 that was closed due to the opener
converting to php.

Here is a copy of my test script:

#!/usr/bin/perl
print "Content-type: text/html\n\n";
print "Hello, World.";


when I try to open that URL I get:

Server error!

    The server encountered an internal error and was unable to
complete your request. 

    Error message:
    Premature end of script headers: first.pl 

    If you think this is a server error, please contact the webmaster 

Error 500



Version-Release number of selected component (if applicable):
perl-5.8.0-88.3

How reproducible:
Always

Steps to Reproduce:
1. try to open URL to a pl script in Apache
2.
3.
    

Actual Results:  500 Error

Additional info:
Comment 1 Alex Weeks 2003-12-19 10:03:31 EST
I found that somehow the permissions on my /usr/bin directory got
changes and apache didn't have permission to execute /usr/bin/perl

Issue resolved!

Note You need to log in before you can comment on or make changes to this bug.