Bug 1122377 - [SNAPSHOT]: activate and deactivate doesn't do a handshake when a glusterd comes back
Summary: [SNAPSHOT]: activate and deactivate doesn't do a handshake when a glusterd co...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: pre-release
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact:
URL:
Whiteboard: SNAPSHOT
Depends On: 1122064
Blocks: 1202388 1219744
TreeView+ depends on / blocked
 
Reported: 2014-07-23 06:23 UTC by Avra Sengupta
Modified: 2016-06-16 12:39 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1122064
: 1219744 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:39:37 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-02-17 10:04:07 UTC
REVIEW: http://review.gluster.org/9664 (snapshot : Handshake with glusterd is not proper.) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-02-19 05:52:54 UTC
REVIEW: http://review.gluster.org/9664 (snapshot :Handshake with glusterd is not proper.) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Anand Avati 2015-04-01 08:12:51 UTC
REVIEW: http://review.gluster.org/9664 (snapshot :Handshake with glusterd is not proper) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 4 Anand Avati 2015-04-02 13:48:13 UTC
REVIEW: http://review.gluster.org/9664 (snapshot :Handshake with glusterd is not proper) posted (#4) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 5 Anand Avati 2015-04-09 13:02:45 UTC
REVIEW: http://review.gluster.org/9664 (snapshot :Handshake with glusterd is not proper) posted (#5) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 6 Anand Avati 2015-04-10 09:09:53 UTC
REVIEW: http://review.gluster.org/9664 (snapshot :Handshake with glusterd is not proper) posted (#6) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 7 Anand Avati 2015-04-14 06:02:03 UTC
REVIEW: http://review.gluster.org/9664 (snapshot :Handshake with glusterd is not proper) posted (#7) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 8 Anand Avati 2015-04-22 06:12:28 UTC
REVIEW: http://review.gluster.org/9664 (snapshot :Handshake with glusterd is not proper.) posted (#8) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 9 Anand Avati 2015-04-23 17:02:51 UTC
REVIEW: http://review.gluster.org/9664 (snapshot :Handshake with glusterd is not proper) posted (#9) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 10 Anand Avati 2015-05-04 07:27:29 UTC
REVIEW: http://review.gluster.org/9664 (snapshot :Handshake with glusterd is not proper) posted (#10) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 11 Anand Avati 2015-05-04 08:51:26 UTC
REVIEW: http://review.gluster.org/9664 (snapshot :Handshake with glusterd is not proper) posted (#11) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 12 Anand Avati 2015-05-04 09:04:58 UTC
REVIEW: http://review.gluster.org/9664 (snapshot :Handshake with glusterd is not proper) posted (#12) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 13 Anand Avati 2015-05-05 05:55:38 UTC
REVIEW: http://review.gluster.org/9664 (snapshot: Handshake with glusterd is not proper) posted (#13) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 14 Anand Avati 2015-05-06 06:00:02 UTC
REVIEW: http://review.gluster.org/9664 (snapshot: Handshake with glusterd is not proper) posted (#14) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 15 Anand Avati 2015-05-07 09:27:48 UTC
COMMIT: http://review.gluster.org/9664 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 82684f1efeb1685a1c794c1c875e3ac21f810481
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Thu Feb 12 18:59:35 2015 +0530

    snapshot: Handshake with glusterd is not proper
    
    If a snap is activated or deactivated, when a node is down,
    it is not retrieving the data properly during the handshake
    of glusterd
    
    With this patch, a version check will made when a glusterd
    is started running. If there is a mismach in version, then
    peers will exchange the healed data.
    
    Change-Id: I8bd2a347723db2194d3fa73295878b4dd2e9be5d
    BUG: 1122377
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/9664
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Tested-by: NetBSD Build System
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 16 Kaleb KEITHLEY 2015-10-22 15:40:20 UTC
pre-release version is ambiguous and about to be removed as a choice.

If you believe this is still a bug, please change the status back to NEW and choose the appropriate, applicable version for it.

Comment 17 Niels de Vos 2016-06-16 12:39:37 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.