Bug 1122393 - bind-dyndb-ldap crash during 389-ds-base restart
Summary: bind-dyndb-ldap crash during 389-ds-base restart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bind-dyndb-ldap
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Spacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 07:00 UTC by Martin Kosek
Modified: 2014-09-23 05:09 UTC (History)
3 users (show)

Fixed In Version: bind-dyndb-ldap-5.3-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-19 10:13:11 UTC


Attachments (Terms of Use)

Description Martin Kosek 2014-07-23 07:00:11 UTC
Description of problem:
After I restart dirsrv in running FreeIPA server, named crashes:

23-Jul-2014 08:58:27.935 zone localhost.localdomain/IN: loaded serial 0
23-Jul-2014 08:58:27.936 zone localhost/IN: loaded serial 0
23-Jul-2014 08:58:27.936 all zones loaded
23-Jul-2014 08:58:27.938 running
23-Jul-2014 08:58:28.074 zone 47.34.10.in-addr.arpa/IN: loaded serial 1406098708
23-Jul-2014 08:58:28.075 zone mkosek-fedora20.test/IN: loaded serial 1406098707
23-Jul-2014 08:58:28.075 2 zones from LDAP instance 'ipa' loaded (2 zones defined)
23-Jul-2014 08:58:35.755 LDAP error: Can't contact LDAP server: ldap_sync_poll() failed
23-Jul-2014 08:58:35.786 zone.c:16423: REQUIRE((((zone) != ((void *)0)) && (((const isc__magic_t *)(zone))->magic == ((('Z') << 24 | ('O') << 16 | ('N') << 8 | ('E')))))) failed, back trace
23-Jul-2014 08:58:35.787 #0 0x7f664abe0920 in ??
23-Jul-2014 08:58:35.787 #1 0x7f6648dd017a in ??
23-Jul-2014 08:58:35.787 #2 0x7f664a508e8e in ??
23-Jul-2014 08:58:35.787 #3 0x7f6644c78a8c in ??
23-Jul-2014 08:58:35.787 #4 0x7f6644c7cbd4 in ??
23-Jul-2014 08:58:35.788 #5 0x7f66489a6f33 in ??
23-Jul-2014 08:58:35.788 #6 0x7f6647c4aded in ??
23-Jul-2014 08:58:35.788 exiting (due to assertion failure)

Program received signal SIGABRT, Aborted.
[Switching to Thread 0x7f663ddbd700 (LWP 10582)]
0x00007f6647b8bc39 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);


Version-Release number of selected component (if applicable):
freeipa-server-4.0.0GIT3e64386-0.fc20.x86_64
bind-dyndb-ldap-5.0-1.fc20.x86_64
389-ds-base-1.3.2.19-1.fc20.x86_64
selinux-policy-3.12.1-177.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install FreeIPA server
2. Restart dirsrv@THE-REALM service
3.

Actual results:
named crashes

Expected results:
named does not crash.

Additional info:

Comment 1 Petr Spacek 2014-07-24 10:02:58 UTC
Fixed by upstream commit: fb979d2f07be16f8cf441d393612504235ab26d8

Comment 2 Fedora Update System 2014-07-24 10:59:50 UTC
bind-dyndb-ldap-5.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/bind-dyndb-ldap-5.1-1.fc20

Comment 3 Fedora Update System 2014-07-25 10:09:19 UTC
Package bind-dyndb-ldap-5.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bind-dyndb-ldap-5.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8861/bind-dyndb-ldap-5.1-1.fc20
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-09-08 11:39:27 UTC
bind-dyndb-ldap-5.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/bind-dyndb-ldap-5.2-1.fc21

Comment 5 Fedora Update System 2014-09-08 14:14:52 UTC
bind-dyndb-ldap-4.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/bind-dyndb-ldap-4.5-1.fc20

Comment 6 Fedora Update System 2014-09-12 14:24:22 UTC
bind-dyndb-ldap-5.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/bind-dyndb-ldap-5.3-1.fc21

Comment 7 Fedora Update System 2014-09-19 10:13:11 UTC
bind-dyndb-ldap-4.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-09-23 05:09:36 UTC
bind-dyndb-ldap-5.3-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.