Bug 1122403 - docker kill accepts 0 as valid signal
Summary: docker kill accepts 0 as valid signal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matthew Heon
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1109938
TreeView+ depends on / blocked
 
Reported: 2014-07-23 07:37 UTC by Lukas Doktor
Modified: 2019-03-06 01:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-18 20:46:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1266 normal SHIPPED_LIVE docker bug fix and enhancement update 2014-09-19 00:45:12 UTC

Description Lukas Doktor 2014-07-23 07:37:25 UTC
Description of problem:
Hi guys, `docker kill -s 0 ...` sends signal 9 instead.

Version-Release number of selected component (if applicable):
docker-1.1.1-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. docker run -t -i fedora bash
2. docker kill -s 0 $ID

Actual results:
Container is killed with signal 9 (SIGKILL)

Expected results:
Error: Invalid signal: 0 should be raised

Comment 2 Matthew Heon 2014-07-24 13:30:32 UTC
Looks like a logic error when parsing the -s flag - I'll send a pull request upstream with a patch for this.

Comment 3 Matthew Heon 2014-07-24 14:03:14 UTC
Pull request sent to upstream with a fix: https://github.com/dotcloud/docker/pull/7212

I'll see about having it included in the next RHEL7 build of Docker.

Comment 4 Lukas Doktor 2014-08-11 07:59:43 UTC
Fixed in docker-1.1.2-9.el7.x86_64

Comment 5 errata-xmlrpc 2014-09-18 20:46:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1266.html


Note You need to log in before you can comment on or make changes to this bug.