Bug 1122415 - SELinux is preventing /usr/bin/gdb from 'unlink' accesses on the file weakref.pyc.
Summary: SELinux is preventing /usr/bin/gdb from 'unlink' accesses on the file weakref...
Keywords:
Status: CLOSED DUPLICATE of bug 1122414
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:fc2cdd74a96cc23553bb658424f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 08:04 UTC by jaroslaw.herod
Modified: 2014-07-23 09:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-23 09:46:57 UTC


Attachments (Terms of Use)

Description jaroslaw.herod 2014-07-23 08:04:14 UTC
Description of problem:
SELinux is preventing /usr/bin/gdb from 'unlink' accesses on the file weakref.pyc.

*****  Plugin catchall (100. confidence) suggests   **************************

If aby gdb powinno mieć domyślnie unlink dostęp do weakref.pyc file.
Then proszę to zgłosić jako błąd.
Można utworzyć lokalny moduł polityki, aby umożliwić ten dostęp.
Do
można tymczasowo zezwolić na ten dostęp wykonując polecenia:
# grep gdb /var/log/audit/audit.log | audit2allow -M mojapolityka
# semodule -i mojapolityka.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:lib_t:s0
Target Objects                weakref.pyc [ file ]
Source                        gdb
Source Path                   /usr/bin/gdb
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdb-7.6.50.20130731-19.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-122.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.13.3-201.fc20.x86_64 #1 SMP Fri
                              Feb 14 19:08:32 UTC 2014 x86_64 x86_64
Alert Count                   1
First Seen                    2014-02-24 21:22:17 CET
Last Seen                     2014-02-24 21:22:17 CET
Local ID                      d6370351-15cb-4049-8451-afbd9c948683

Raw Audit Messages
type=AVC msg=audit(1393273337.935:658): avc:  denied  { unlink } for  pid=13166 comm="gdb" name="weakref.pyc" dev="dm-1" ino=398707 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:lib_t:s0 tclass=file


type=SYSCALL msg=audit(1393273337.935:658): arch=x86_64 syscall=unlink success=yes exit=0 a0=104a810 a1=13560 a2=81a4 a3=7f660dc865d0 items=0 ppid=13165 pid=13166 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=gdb exe=/usr/bin/gdb subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)

Hash: gdb,abrt_t,lib_t,file,unlink

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.15.6-200.fc20.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-07-23 09:46:57 UTC

*** This bug has been marked as a duplicate of bug 1122414 ***


Note You need to log in before you can comment on or make changes to this bug.