Bug 1122417 - Writing data to a dispersed volume mounted by NFS fails
Summary: Writing data to a dispersed volume mounted by NFS fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 08:04 UTC by Xavi Hernandez
Modified: 2015-05-14 17:42 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1126734 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:26:28 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2014-07-23 08:04:43 UTC
Description of problem:

When a dispersed volume is mounted by NFS, any write to it returns an error and nothing is written (file size is 0).

Version-Release number of selected component (if applicable): 3.6


How reproducible:

Always

Steps to Reproduce:
1. gluster volume create d3_1 disperse node1:/bricks/d3_1 node2:/bricks/d3_1 node3:/bricks/d3_1
2. gluster volume start d3_1
3. mount node1:/d3_1 /gluster/d3_1
4. dd if=/dev/zero of=/gluster/d3_1/test bs=1024k count=1k

Actual results:

dd: error writing ‘/gluster/d3_1/test’: Unknown error 527
470+0 records in
469+0 records out
491782144 bytes (492 MB) copied, 3.41857 s, 144 MB/s

Expected results:

The file should be successfully written

Additional info:

The problem is caused because NFS uses anonymous fd, even for writes. Anonymous fs are not correctly handled by ec xlator.

Comment 1 Anand Avati 2014-07-23 14:19:26 UTC
REVIEW: http://review.gluster.org/8367 (cluster/ec: Fix incorrect management of NFS requests) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 2 Anand Avati 2014-08-02 07:23:31 UTC
COMMIT: http://review.gluster.org/8367 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit f3204a06eb8156743110b1613b4b4b63b70572b6
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Tue Jul 8 17:52:57 2014 +0200

    cluster/ec: Fix incorrect management of NFS requests
    
    Some operations, specially those comming from NFS, do not use a
    regular fd and use an anonymous fd (i.e. a previous open call has
    not been sent). Any context information created during open or
    create will not be present on these fd's, so we simply return NULL
    for contexts of those fd.
    
    Also it seems that NFS can send write requests with a very big
    buffer (higher that the default value of 128 KB). Some changes
    have been made to correctly handle these large buffers.
    
    Change-Id: I281476bd0d2cbaad231822248d6a616fcf5d4003
    BUG: 1122417
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/8367
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 3 Niels de Vos 2015-05-14 17:26:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 4 Niels de Vos 2015-05-14 17:35:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:37:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:42:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.