Bug 1122418 - SELinux is preventing /usr/bin/gdb from 'write' accesses on the directory /usr/lib64/python2.7/encodings.
Summary: SELinux is preventing /usr/bin/gdb from 'write' accesses on the directory /us...
Keywords:
Status: CLOSED DUPLICATE of bug 1122414
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:0bdcca573488b118213ee42108c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 08:04 UTC by jaroslaw.herod
Modified: 2017-11-28 13:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-23 09:47:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1518224 None None None Never

Internal Links: 1518224

Description jaroslaw.herod 2014-07-23 08:04:54 UTC
Description of problem:
SELinux is preventing /usr/bin/gdb from 'write' accesses on the directory /usr/lib64/python2.7/encodings.

*****  Plugin catchall (100. confidence) suggests   **************************

If aby gdb powinno mieć domyślnie write dostęp do encodings directory.
Then proszę to zgłosić jako błąd.
Można utworzyć lokalny moduł polityki, aby umożliwić ten dostęp.
Do
można tymczasowo zezwolić na ten dostęp wykonując polecenia:
# grep gdb /var/log/audit/audit.log | audit2allow -M mojapolityka
# semodule -i mojapolityka.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:lib_t:s0
Target Objects                /usr/lib64/python2.7/encodings [ dir ]
Source                        gdb
Source Path                   /usr/bin/gdb
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdb-7.6.50.20130731-19.fc20.x86_64
Target RPM Packages           python-libs-2.7.5-10.fc20.x86_64 python-
                              libs-2.7.5-11.fc20.x86_64
Policy RPM                    selinux-policy-3.12.1-122.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.13.3-201.fc20.x86_64 #1 SMP Fri
                              Feb 14 19:08:32 UTC 2014 x86_64 x86_64
Alert Count                   2
First Seen                    2014-02-24 21:22:14 CET
Last Seen                     2014-02-24 21:22:16 CET
Local ID                      e32aab05-e267-41a5-8eb0-768c6b1134ed

Raw Audit Messages
type=AVC msg=audit(1393273336.579:656): avc:  denied  { write } for  pid=13166 comm="gdb" name="encodings" dev="dm-1" ino=397336 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:lib_t:s0 tclass=dir


type=AVC msg=audit(1393273336.579:656): avc:  denied  { remove_name } for  pid=13166 comm="gdb" name="__init__.pyc" dev="dm-1" ino=403174 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:lib_t:s0 tclass=dir


type=SYSCALL msg=audit(1393273336.579:656): arch=x86_64 syscall=unlink success=yes exit=0 a0=f54b80 a1=9c60 a2=81a4 a3=7f660dc865d0 items=0 ppid=13165 pid=13166 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=gdb exe=/usr/bin/gdb subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)

Hash: gdb,abrt_t,lib_t,dir,write

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.15.6-200.fc20.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-07-23 09:47:13 UTC

*** This bug has been marked as a duplicate of bug 1122414 ***


Note You need to log in before you can comment on or make changes to this bug.