Bug 1122443 - Symlink mtime changes when rebalancing
Summary: Symlink mtime changes when rebalancing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: pre-release
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1146413
TreeView+ depends on / blocked
 
Reported: 2014-07-23 09:30 UTC by Anders Blomdell
Modified: 2015-05-14 17:42 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1146413 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:26:29 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Anders Blomdell 2014-07-23 09:30:36 UTC
Description of problem:

When migrating approx 1 GB of data data by doing 

  gluster volume add-brick test new-host1:/path/to/new/brick ...
  gluster volume remove-brick old-host1:/path/to/old/brick ... start
  ... wait for removal to finish
  gluster volume remove-brick old-host1:/path/to/old/brick ... commit

on a 3*4 -> 6*4 -> 3*4 gluster [version  3.7dev-0.9.git5b8de97] approximately
40% of the symlinks change their mtime to the time they were copied. 


Version-Release number of selected component (if applicable):

3.7dev-0.9.git5b8de97

How reproducible:

Unknown (once so far), will try to come up with a reproducible (and hopefully smaller) test case.

Comment 1 Anand Avati 2014-07-29 15:15:30 UTC
REVIEW: http://review.gluster.org/8383 (Symlink mtime changes when rebalancing) posted (#1) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 2 Anand Avati 2014-07-29 16:47:54 UTC
REVIEW: http://review.gluster.org/8383 (Symlink mtime changes when rebalancing) posted (#2) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 3 Anand Avati 2014-07-29 17:12:55 UTC
REVIEW: http://review.gluster.org/8383 (Symlink mtime changes when rebalancing) posted (#3) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 4 Anand Avati 2014-07-30 10:30:38 UTC
REVIEW: http://review.gluster.org/8383 (Symlink mtime changes when rebalancing) posted (#4) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 5 Anand Avati 2014-07-31 16:08:06 UTC
COMMIT: http://review.gluster.org/8383 committed in master by Anand Avati (avati@redhat.com) 
------
commit a278c2aecedfbe17e2749109d73b292ca25ff439
Author: Anders Blomdell <anders.blomdell@control.lth.se>
Date:   Tue Jul 29 17:11:20 2014 +0200

    Symlink mtime changes when rebalancing
    
    Added mtime preservation for special files during rebalance.
    
    Change-Id: If04921d4d66853fde8b4d8a3ab748790864f8f42
    BUG: 1122443
    Signed-off-by: Anders Blomdell <anders.blomdell@control.lth.se>
    Reviewed-on: http://review.gluster.org/8383
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    Reviewed-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-by: Anand Avati <avati@redhat.com>

Comment 6 Niels de Vos 2015-05-14 17:26:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:35:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:37:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:42:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.