Bug 1122450 - migration cluster policy changed to default once engine restart [NEEDINFO]
Summary: migration cluster policy changed to default once engine restart
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Roy Golan
QA Contact: Artyom
URL:
Whiteboard: sla
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 09:54 UTC by Eldad Marciano
Modified: 2016-02-10 20:14 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-17 17:15:50 UTC
oVirt Team: SLA
Target Upstream Version:
rgolan: needinfo?


Attachments (Terms of Use)

Description Eldad Marciano 2014-07-23 09:54:12 UTC
Description of problem:
looks like the migration policy were changed once the engine restarted.
i have setup my cluster resilience policy to 'do not migrate vms'
after engine restarted this policy changed back to 'migrate virtual machine'

logs are not available. 


*** I'm not sure if it is duplicated to this https://bugzilla.redhat.com/show_bug.cgi?id=739931

this BZ reflect the change just in the gui, more test are required.
for mine, the vms are really migrating once the engine restart and the policy changed.

Version-Release number of selected component (if applicable):
3.4.0.2

How reproducible:
90%

Steps to Reproduce:
1.set the the cluster policy to 'do not migrate'
2.restart the engine

Actual results:
this value influenced from restart. 

Expected results:
this value should be static and not influenced from any restart

Additional info:

Comment 1 Eldad Marciano 2014-07-23 09:58:16 UTC
seems to be a regression.

Comment 2 Martin Sivák 2014-07-24 13:21:09 UTC
This seems to work properly in 3.5. I just tested that with my engine and the resilience policy stayed where I set it.

Comment 3 Roy Golan 2014-11-06 07:54:19 UTC
The only code path that sets migrate_on_error to "do not migrate" (oposite from what you see) is in HandleVdsCpuFlagsOrClusterChangedCommand and is relevant when ConfigValue.IsMigrationSupported is set to false.

proposing to close as it is not reproducing

Comment 4 Doron Fediuck 2014-11-17 17:15:50 UTC
Please re-open if relevant and provide a clear reproducer on a clean setup.


Note You need to log in before you can comment on or make changes to this bug.