Bug 1122451 - openlmi-storage rebase
Summary: openlmi-storage rebase
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openlmi-storage
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Jan Safranek
QA Contact: Barry Donahue
URL:
Whiteboard:
Depends On:
Blocks: 1082756
TreeView+ depends on / blocked
 
Reported: 2014-07-23 09:59 UTC by Jan Safranek
Modified: 2015-03-05 09:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 09:08:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0418 normal SHIPPED_LIVE openlmi-storage bug fix and enhancement update 2015-03-05 14:04:47 UTC

Description Jan Safranek 2014-07-23 09:59:17 UTC
There's been active upstream development in OpenLMI since last release, including both new features and lots of bugfixes.

The API of recent version should be backwards compatible with current version.

New features:
- LVM thin provisioning
- extending/reducing volume groups

Significant changes:
- we need to update openlmi-storage to new python-blivet API, heading to 7.1

Comment 1 Jan Safranek 2014-09-03 13:59:26 UTC
Full upstream announce:

* Added support for thin provisioning in LVM. The provider can now create / delete thin pools and thin volumes.
* Added support for volume group modification - devices can be added / removed from a volume group.
* Added LMI_StorageExtent.DeviceBusType property to show how a block device is connected to the system (ATA, USB or SCSI).
* Added LMI_StorageConfigurationService.LMI_SCSIScan() to re-scan local SCSI bus and discover new devices.
* Added support for blivet version > 0.35.
* Many small fixes and improvements.


(I am still waiting for final blivet before I release it, but I expect just small bugfixes in the worst case)

Comment 4 Barry Donahue 2015-01-08 15:35:27 UTC
New functionality verified and added to regression test.

Comment 6 errata-xmlrpc 2015-03-05 09:08:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0418.html


Note You need to log in before you can comment on or make changes to this bug.