Bug 1122479 - Hammer set-parameter overwrites existing value when adding new different parameter
Summary: Hammer set-parameter overwrites existing value when adding new different para...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.0.3
Hardware: Unspecified
OS: Linux
unspecified
high vote
Target Milestone: Unspecified
Assignee: Martin Bacovsky
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2014-07-23 11:19 UTC by Ade Bradshaw
Modified: 2016-04-22 16:41 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-09-11 12:24:02 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6768 None None None 2016-04-22 16:41 UTC

Description Ade Bradshaw 2014-07-23 11:19:50 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Very

Steps to Reproduce:
1. Create a HostGroup
2. add params kt_org, kt_env, kt_cv
3. Display actual hostgroup info

Actual results:
Only 1 param is actually set "kt_org"

Expected results:
All three params be set "kt_org" "kt_cv" & "kt_env"


Additional info:
These are the commands I ran

# hammer hostgroup create --name "RHEL-65" --operatingsystem-id 1 --domain-id 1 --environment-id 1 --puppet-proxy-id 1 --subnet-id 1 --architecture-id 1  --ptable-id 7  --medium-id 7 --environment-id 2 --puppet-ca-proxy-id 1
    Hostgroup created
 
# hammer hostgroup set-parameter --hostgroup-id 4 --name kt_org --value Hilti
    New hostgroup parameter created
# hammer hostgroup set-parameter --hostgroup-id 4 --name kt_env --value Library
    Hostgroup parameter updated
# hammer hostgroup set-parameter --hostgroup-id 4 --name kt_cv --value  HOI-6_5_0-ci
    Hostgroup parameter updated
 
# hammer hostgroup info --id 4
    Id:                     4
    Name:                   RHEL-65
    Label:                
    Operating System:       RHEL Server 6.5
    Environment:            KT_Hilti_Library_HOI_6_5_0_ci_4
    Model:                
    Ancestry:              
    Subnet:                 abcloud-ovirt-vlan
    Domain:                 abcloud.pw
    Architecture:           x86_64
    Partition Table:        Kickstart default
    Medium:                 Hilti/Library/Red_Hat_6_Server_Kickstart_x86_64_6_5
    Puppet CA Proxy Id:     1
    Puppet Master Proxy Id: 1
    ComputeProfile:        
    Puppetclasses:        
 
    Parameters:            
        kt_org => HOI-6_5_0-ci

Comment 1 RHEL Product and Program Management 2014-07-23 11:34:02 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-07-24 13:36:20 UTC
Created redmine issue http://projects.theforeman.org/issues/6768 from this bug

Comment 4 Bryan Kearney 2014-07-29 14:04:38 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6768 has been closed
-------------
Anonymous
Applied in changeset commit:1eaa44cab92bd1a89d56b3ec022eab0704ba7281.

Comment 7 sthirugn@redhat.com 2014-08-07 18:55:48 UTC
Verified.

hammer> hostgroup set-parameter --hostgroup-id=4 --name kt_org --value Hilti
Hostgroup parameter updated

hammer> hostgroup set-parameter --hostgroup-id=4 --name kt_env --value Library
Hostgroup parameter updated

hammer> hostgroup set-parameter --hostgroup-id=4 --name kt_cv --value HOI-6_5_0-ci
Hostgroup parameter updated

hammer> hostgroup info --id 4
Id:                     4
Name:                   hostgroup2
Label:                  
Operating System:       
Environment:            KT_newcorp_Library_cv1_22
Model:                  
Ancestry:               
Subnet:                 
Domain:                 
Architecture:           
Partition Table:        
Medium:                 
Puppet CA Proxy Id:     1
Puppet Master Proxy Id: 1
ComputeProfile:         
Puppetclasses:          

Parameters:             
    kt_cv => HOI-6_5_0-ci
    kt_env => Library
    kt_org => Hilti
Organizations:          
    newcorp

Version Tested:
GA Snap 4 - Satellite-6.0.4-RHEL-6-20140806.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.38-1.el6sat.noarch
* foreman-compute-1.6.0.38-1.el6sat.noarch
* foreman-gce-1.6.0.38-1.el6sat.noarch
* foreman-libvirt-1.6.0.38-1.el6sat.noarch
* foreman-ovirt-1.6.0.38-1.el6sat.noarch
* foreman-postgresql-1.6.0.38-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.38-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.57-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64

Comment 9 Bryan Kearney 2014-09-11 12:24:02 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.