Bug 112248 - /etc/X11/prefdm never start kdm or xdm
/etc/X11/prefdm never start kdm or xdm
Status: CLOSED DUPLICATE of bug 72486
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2003-12-16 12:38 EST by Roger Jordan
Modified: 2014-03-16 22:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Roger Jordan 2003-12-16 12:38:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Description of problem:
This code: 

if [ -f /etc/sysconfig/desktop ]; then
        . /etc/sysconfig/desktop
        if [ "$DISPLAYMANAGER" = GNOME ]; then
        elif [ "$DISPLAYMANAGER" = KDE ]; then
        elif [ "$DISPLAYMANAGER" = XDM ]; then

looks for the $DISPLAYMANAGER variable but in the
/etc/sysconfig/desktop  the variable is called DESKTOP.

DISPLAYMANAGER is not defined in other places (I think ...) so the
condition will allways be false.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.define in /etc/sysconfig/desktop DESKTOP="KDE"

Actual Results:  when graphic mode go on gdm started, no kdm.

Expected Results:  kdm running 

Additional info:

if I define in /etc/sysconfig/desktop DISPLAYMANAGER="KDE" kdm start
after reboot.
Comment 1 Roger Jordan 2003-12-16 12:45:36 EST
The code is in the /etc/X11/prefdm file, sorry ...
Comment 2 Bill Nottingham 2003-12-16 12:49:12 EST
This was intentional.

*** This bug has been marked as a duplicate of 72486 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:00:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.