Bug 1122483 - Fail while trying to deploy hosted-engine over VLAN tagged bonded interface
Summary: Fail while trying to deploy hosted-engine over VLAN tagged bonded interface
Keywords:
Status: CLOSED DUPLICATE of bug 1121145
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.4.1-1
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: Michael Burman
URL:
Whiteboard: network
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 11:22 UTC by Michael Burman
Modified: 2016-02-10 19:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-24 12:00:34 UTC
oVirt Team: Network


Attachments (Terms of Use)
Relevant logs (68.79 KB, application/x-gzip)
2014-07-23 11:22 UTC, Michael Burman
no flags Details

Description Michael Burman 2014-07-23 11:22:28 UTC
Created attachment 920198 [details]
Relevant logs

Description of problem:
Fail to deploy hosted-engine over VLAN tagged bonded interface.
With error:Failed to execute stage 'Misc configuration': Command '/usr/bin/vdsClient' failed to execute.
 

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.1.3-2.el6ev.noarch

How reproducible:
always

Steps to Reproduce:
1. clean rhel host. 
2. configure VLAN over bond.
3. run-yum install ovirt-hosted-engine-setup and then hosted-engine --deploy
4. choose VLAN over bond for rhevm network interface

Actual results:
Fail to deploy hosted-engine.

Expected results:
Hosted-engine deploy should support Vlan-tagged interfaces

Additional info:

Comment 1 Dan Kenigsberg 2014-07-24 12:00:34 UTC
Thread-12::ERROR::2014-07-23 11:49:46,244::sampling::438::vds::(run) Error while sampling stats
Traceback (most recent call last):
  File "/usr/share/vdsm/sampling.py", line 420, in run
    sample = self.sample()
  File "/usr/share/vdsm/sampling.py", line 410, in sample
    hs = HostSample(self._pid)
  File "/usr/share/vdsm/sampling.py", line 186, in __init__
    (link.name, InterfaceSample(link)) for link in getLinks())
  File "/usr/share/vdsm/sampling.py", line 186, in <genexpr>
    (link.name, InterfaceSample(link)) for link in getLinks())
  File "/usr/share/vdsm/sampling.py", line 109, in __init__
    self.speed = _getLinkSpeed(link)
  File "/usr/share/vdsm/sampling.py", line 547, in _getLinkSpeed
    speed = netinfo.vlanSpeed(dev.name)
AttributeError: 'module' object has no attribute 'vlanSpeed'

*** This bug has been marked as a duplicate of bug 1121145 ***


Note You need to log in before you can comment on or make changes to this bug.