Bug 112254 - LANG=de_AT.UTF-8 doesn't cause Mozilla to use the German translation
LANG=de_AT.UTF-8 doesn't cause Mozilla to use the German translation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-16 13:49 EST by Gabriel Ebner
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-12 13:18:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel Ebner 2003-12-16 13:49:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4.1)
Gecko/20031114

Description of problem:
If I start mozilla with LANG=de_AT.UTF-8 set, it won't use the German
translation, but rather does use the hard-coded strings, just like if
started with LANG=C set.

The problem originates in /usr/bin/mozilla (line 184, 185), where the
script does only check wheter there's an exact match in
/usr/lib/mozilla-1.4.1/chrome/*.jar for the current locale.

This does not play nice with different country codes. I.e. it does
only work with de-DE, not with de-AT, because
/usr/lib/mozilla-1.4.1/chrome/de-AT.jar doesn't exist, while
.../de-DE.jar does.

A working solution would be to always pass the -UILocale argument, not
only if /usr/lib/mozilla-1.4.1/chrome/$MOZLOCALE.jar exists, since
mozilla does the checking on its own and would even fallback to a
genericc German translation.

Version-Release number of selected component (if applicable):
1.4.1-18

How reproducible:
Always

Steps to Reproduce:
1. Make sure not to have any mozilla started (/usr/bin/mozilla will
then only pass a command to the running instance)

2. LANG=de_DE.UTF-8 /usr/bin/mozilla
Watch it being German.

3. Kill it. Redo step 1.

4. LANG=de_AT.UTF-8 /usr/bin/mozilla
Watch it being English.

Actual Results:  Step 4) started mozilla using English translation
because /usr/bin/mozilla had executed
/usr/lib/mozilla-1.4.1/mozilla.bin without any -UILocale argument.

Expected Results:  It should have rather been an Austrian German
translation or a German translation as a fallback.

Additional info:

Step 2) exec's /usr/lib/mozilla-1.4.1/mozilla.bin -UILocale de-DE

Step 4) exec's /usr/lib/mozilla-1.4.1/mozilla.bin
Comment 1 Yue Shi Lai 2003-12-16 21:56:02 EST
The German Mozilla translation is actually for the locale de_AT
(please refer to the Mozilla l10n project), which makes this problem
even more weird.
Comment 2 Gabriel Ebner 2003-12-17 17:10:45 EST
In what way does it being de-AT make the problem any more weird?

It works just fine with either -UILocale de-AT or -UILocale de-DE
Comment 3 Christopher Blizzard 2004-02-12 13:18:38 EST
The translation was originally de_AT and I changed to to be de_DE
since that was our target.  We don't ship a specific de_AT pack.
Comment 4 Gabriel Ebner 2004-02-12 15:15:47 EST
> We don't ship a specific de_AT pack.

My point was that /usr/bin/mozilla shouldn't check whether the given
locale exists or not as mozilla does this on its own because I get an
English mozilla under my de_AT.UTF-8 install.

It works just fine (i.e. German) with LANG=de_DE.UTF-8 set, as I
mentioned in the bug report.

Note You need to log in before you can comment on or make changes to this bug.