Bug 1122560 - [abrt] jboss-modules-1.3.3-1.fc20: Uncaught exception org.jboss.modules.ModuleLoadError in method javax.management.MBeanServerFactory.newMBeanServer()
Summary: [abrt] jboss-modules-1.3.3-1.fc20: Uncaught exception org.jboss.modules.Modul...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: jboss-modules
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Goldmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e922fcac4f462589d0342554926...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 14:03 UTC by kluksa
Modified: 2014-08-23 01:55 UTC (History)
3 users (show)

Fixed In Version: wildfly-8.1.0-3.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-23 01:55:07 UTC


Attachments (Terms of Use)
File: backtrace (9.73 KB, text/plain)
2014-07-23 14:03 UTC, kluksa
no flags Details
File: environ (293 bytes, text/plain)
2014-07-23 14:03 UTC, kluksa
no flags Details
File: jvm_environment (1.98 KB, text/plain)
2014-07-23 14:03 UTC, kluksa
no flags Details

Description kluksa 2014-07-23 14:03:29 UTC
Version-Release number of selected component:
jboss-modules-1.3.3-1.fc20

Additional info:
reporter:       libreport-2.2.2
cmdline:        java -agentpath:/usr/lib64/libabrt-java-connector.so=abrt=on -D[Standalone] -server -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true -Dorg.jboss.boot.log.file=/usr/share/wildfly/standalone/log/server.log -Dlogging.configuration=file:/usr/share/wildfly/standalone/configuration/logging.properties -jar /usr/share/wildfly/jboss-modules.jar -mp /usr/share/wildfly/modules org.jboss.as.standalone -Djboss.home.dir=/usr/share/wildfly -Djboss.server.base.dir=/usr/share/wildfly/standalone -c standalone.xml -b 0.0.0.0
executable:     /usr/share/java/jboss-modules/jboss-modules.jar
java_executable: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.5.0.1.fc20.x86_64/jre-abrt/bin/java
kernel:         3.14.9-200.fc20.x86_64
pid:            13677
runlevel:       N 5
uid:            185

Truncated backtrace:
#1 org.jboss.modules.xml.XmlPullParserException: Failed to add resource root 'jboss-marshalling-river.jar' at path 'jboss-marshalling-river.jar' (position: END_TAG seen ...urces>\n        <resource-root path="jboss-marshalling-river.jar"/>... @31:60) caused by: java.io.FileNotFoundException: /usr/share/wildfly/modules/system/layers/base/org/jboss/marshalling/river/main/jboss-marshalling-river.jar (No such file or directory)
#2 	at org.jboss.modules.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.java:723) [file:/usr/share/java/jboss-modules/jboss-modules.jar]
#3 	at org.jboss.modules.ModuleXmlParser.parseResources(ModuleXmlParser.java:572) [file:/usr/share/java/jboss-modules/jboss-modules.jar]
#4 	at org.jboss.modules.ModuleXmlParser.parseModuleContents(ModuleXmlParser.java:394) [file:/usr/share/java/jboss-modules/jboss-modules.jar]
#5 	at org.jboss.modules.ModuleXmlParser.parseDocument(ModuleXmlParser.java:219) [file:/usr/share/java/jboss-modules/jboss-modules.jar]
#6 	at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:153) [file:/usr/share/java/jboss-modules/jboss-modules.jar]
#7 	at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:132) [file:/usr/share/java/jboss-modules/jboss-modules.jar]
#8 	at org.jboss.modules.LocalModuleFinder$1.run(LocalModuleFinder.java:154) [file:/usr/share/java/jboss-modules/jboss-modules.jar]
#9 	at org.jboss.modules.LocalModuleFinder$1.run(LocalModuleFinder.java:148) [file:/usr/share/java/jboss-modules/jboss-modules.jar]
#10 	at java.security.AccessController.doPrivileged(Native Method) [file:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.5.0.1.fc20.x86_64/jre/lib/rt.jar]

Comment 1 kluksa 2014-07-23 14:03:31 UTC
Created attachment 920228 [details]
File: backtrace

Comment 2 kluksa 2014-07-23 14:03:32 UTC
Created attachment 920229 [details]
File: environ

Comment 3 kluksa 2014-07-23 14:03:34 UTC
Created attachment 920230 [details]
File: jvm_environment

Comment 4 Fedora Update System 2014-07-28 11:30:30 UTC
wildfly-8.1.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wildfly-8.1.0-3.fc20

Comment 5 Fedora Update System 2014-07-29 02:07:21 UTC
Package wildfly-8.1.0-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wildfly-8.1.0-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8928/wildfly-8.1.0-3.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-08-23 01:55:07 UTC
wildfly-8.1.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.