Bug 1122569 - Fix some OpenStack init scripts to return non-zero if service cannot start
Summary: Fix some OpenStack init scripts to return non-zero if service cannot start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: distribution
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z5
: 5.0 (RHEL 7)
Assignee: Alan Pevec
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On: 1036515
Blocks: 1040649 RHEL-OSP_Neutron_HA 1098570
TreeView+ depends on / blocked
 
Reported: 2014-07-23 14:14 UTC by Ihar Hrachyshka
Modified: 2016-04-26 16:40 UTC (History)
28 users (show)

Fixed In Version: openstack-neutron-2014.1.5-2.el7ost openstack-nova-2014.1.5-1.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of: 1036515
Environment:
Last Closed: 2015-09-10 11:45:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1762 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix and Enhancement Advisory 2015-09-10 15:45:31 UTC
Red Hat Bugzilla 1067025 None None None Never

Internal Links: 1067025

Comment 1 Ihar Hrachyshka 2014-07-23 14:16:00 UTC
At least Neutron misses daemon_notify.sh wrapper in its packaging.

Comment 3 Ihar Hrachyshka 2014-08-13 11:27:04 UTC
Neutron package is rebuilt with the script. Other projects should be checked on whether they miss it too.

Comment 4 Vladan Popovic 2014-08-13 12:48:39 UTC
nova build done:
openstack-nova-2014.1.2-3.el6ost

build info:
https://brewweb.devel.redhat.com/taskinfo?taskID=7838604

Comment 5 Eric Harney 2014-08-13 16:48:44 UTC
Fixed in Cinder: openstack-cinder-2014.1.2-1.el6ost

Comment 11 Ihar Hrachyshka 2014-11-25 13:35:53 UTC
> removing -rhel-6 flag, will be tested in -rhel-7, and CI only in -rhel-6

I think it's a wrong attitude for the bug. Platforms differ in their init system, and that's what we fix here. The fixes are completely different for two releases, so we should test both.

Comment 12 Jon Schlueter 2015-08-18 13:55:07 UTC
These packages are already released, any others that are an issue or can this be pushed to modified for TestOnly for A5 release?

Comment 13 Alan Pevec 2015-08-19 15:04:05 UTC
Yes, this BZ should be TestOnly at this point.

Comment 19 Toni Freger 2015-09-03 05:59:09 UTC
The fixed packages within the latest osp5 from /5.0-RHEL-7/2015-08-31.1/

openstack-neutron-2014.1.5-2.el7ost.noarch
openstack-nova-api-2014.1.5-1.el7ost.noarch
openstack-cinder-2014.1.5-1.el7ost.noarch 

Reproduction step:

1)mv /usr/bin/python /usr/bin/python-orig
2)stop the process
3)start the process 
4)check the real status of the process 


Processes that worked as expected : neutron-server, openstack-nova-api and openstack-keystone

Comment 22 errata-xmlrpc 2015-09-10 11:45:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1762.html


Note You need to log in before you can comment on or make changes to this bug.