Bug 1122581 - Sometimes self heal on disperse volume crashes
Summary: Sometimes self heal on disperse volume crashes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 14:26 UTC by Xavi Hernandez
Modified: 2015-05-14 17:42 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1140626 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:26:30 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2014-07-23 14:26:42 UTC
Description of problem:

In some circumstances, when healing a file, glusterfs crashes

Version-Release number of selected component (if applicable): 3.6


How reproducible:

It happens sometimes. Not sure how to force it.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2014-07-23 14:28:41 UTC
REVIEW: http://review.gluster.org/8368 (ec: Only heal data/metadata when inode has enough information) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 2 Anand Avati 2014-09-16 06:11:57 UTC
COMMIT: http://review.gluster.org/8368 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 2be54585002cd1c9d02928b89a02047b58dd6aed
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Tue Jul 15 13:42:28 2014 +0200

    ec: Only heal data/metadata when inode has enough information
    
    Sometimes loc_t structure in a heal request doesn't contain enough
    information to do an inodelk call (basically the gfid is missing).
    In these cases, self heal only recovers entry information.
    
    Change-Id: I459990c7df728ff4baf164df046672ddcde3efa5
    BUG: 1122581
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/8368
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

Comment 3 Niels de Vos 2015-05-14 17:26:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 4 Niels de Vos 2015-05-14 17:35:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:37:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:42:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.