Bug 1122586 - Read/write speed on a dispersed volume is poor
Summary: Read/write speed on a dispersed volume is poor
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 14:36 UTC by Xavi Hernandez
Modified: 2015-05-14 17:42 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1140844 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:26:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2014-07-23 14:36:11 UTC
Description of problem:

Dispersed volumes are much slower than replicate

Version-Release number of selected component (if applicable): 3.6


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

This is caused by a sequential inodelk/entrylk for each operation

Comment 1 Anand Avati 2014-07-23 14:37:49 UTC
REVIEW: http://review.gluster.org/8369 (ec: Optimize read/write performance) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 2 Anand Avati 2014-09-10 07:41:11 UTC
REVIEW: http://review.gluster.org/8369 (ec: Optimize read/write performance) posted (#2) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 3 Anand Avati 2014-09-16 06:12:20 UTC
COMMIT: http://review.gluster.org/8369 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit d97863562bb0d2f685df3d2e3aa4bef1299c8307
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Mon Jul 14 17:34:04 2014 +0200

    ec: Optimize read/write performance
    
    This patch significantly improves performance of read/write
    operations on a dispersed volume by reusing previous inodelk/
    entrylk operations on the same inode/entry. This reduces the
    latency of each individual operation considerably.
    
    Inode version and size are also updated when needed instead
    of on each request. This gives an additional boost.
    
    Change-Id: I4b98d5508c86b53032e16e295f72a3f83fd8fcac
    BUG: 1122586
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/8369
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

Comment 4 Niels de Vos 2015-05-14 17:26:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:35:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:37:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:42:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.