Bug 1122591 - Bad error message - no link
Summary: Bad error message - no link
Keywords:
Status: CLOSED DUPLICATE of bug 1122589
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-cli
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.5.0
Assignee: Ravi Nori
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 14:46 UTC by Nelly Credi
Modified: 2016-02-10 19:34 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0_rc1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-20 07:49:20 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30813 master MERGED restapi : Bad error message - no link Never
oVirt gerrit 31023 ovirt-engine-3.5 MERGED restapi : Bad error message - no link Never
oVirt gerrit 31526 ovirt-engine-3.5 MERGED restapi: Remove trailing slashes from RSDL prefix Never

Description Nelly Credi 2014-07-23 14:46:40 UTC
Description of problem:

'See the link description below:' but there is no link

========================================================================================= ERROR ======================================================================================
  status: 400
  reason: Bad Request
  detail: 
<?xml version="1.0" encoding="UTF-8" standalone="yes"?><usage_message><message>Request syntactically incorrect. See the link description below for the correct usage:</message></usage_message>
  ======================================================================================================================================================================================

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.send bad request, for example add user  --domain-name 'xxx' --user_name 'xxx' --expect '201-created'


Actual results:

Error message is not informative - missing link

Expected results:

Informative error message

Additional info:

Comment 1 Barak 2014-07-27 11:33:37 UTC
it looks like the same issue as Bug 1122589,
Ravi - please verify ... if needed close as DUPLICATE

Comment 2 Ravi Nori 2014-08-07 13:51:13 UTC
Hi Nelly

What version did you test with?

Comment 3 Nelly Credi 2014-08-07 14:17:07 UTC
3.5.0.3

This is what we got with rc1

Comment 4 Juan Hernández 2014-08-20 07:49:20 UTC

*** This bug has been marked as a duplicate of bug 1122589 ***


Note You need to log in before you can comment on or make changes to this bug.