Bug 1122599 - wifi drops randomly on Lenovo T420 and must reboot to get it back
Summary: wifi drops randomly on Lenovo T420 and must reboot to get it back
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fedora-kernel-wireless-iwl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 14:55 UTC by Ryan M
Modified: 2014-12-10 11:26 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-10 11:26:16 UTC


Attachments (Terms of Use)

Description Ryan M 2014-07-23 14:55:07 UTC
Description of problem:
Randomly, when connected to wifi, the connection will drop.  I'm guessing this happens more often when the network is under high load, but I'm unsure.  Once the connection has dropped, nothing I have tried except for a reboot can bring it back.  In talking things over on #fedora, it was suggested that this is probably the driver putting the hardware into a bad state.

Version-Release number of selected component (if applicable):
Name        : iwl1000-firmware
Epoch       : 1
Version     : 39.31.5.1
Release     : 38.fc20

(I think that's the right package...)

How reproducible:
Always, if you wait long enough.  I've never had it stay up more than 24 hours.


Steps to Reproduce:
1. Connect to the network
2. Go about business as usual, and eventually it will disconnect.


Actual results:
Connection disconnects, and then gets stuck in "configuring interface" when attempting to reconnect.  Every few minutes in this state it will report the connection was deactivated, and try again.


Expected results:
Wifi stays up, or at least successfully reconnects when it goes down.


Additional info:
The network is using WPA2-PSK encryption.  Signal strength is excellent (~97%).  I've tried restarting network.service, NetworkManager.service, turning wifi on/off both in Network Manager and with the hardware switch, and reloading the iwlwifi kernel model and its dependencies... no change.  Only a reboot fixes the problem.

Here's a description of my hardware: http://paste.fedoraproject.org/120140/24635140/

Comment 1 Stanislaw Gruszka 2014-09-03 14:32:26 UTC
Do you still have this problem on 3.16 kernel ?

Comment 2 Justin M. Forbes 2014-11-13 15:59:54 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.17.2-200.fc20.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 21, and are still experiencing this issue, please change the version to Fedora 21.

If you experience different issues, please open a new bug report for those.


Note You need to log in before you can comment on or make changes to this bug.