Bug 112260 - debug code generates seg fault
debug code generates seg fault
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ypbind (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-16 14:30 EST by Jeff Bastian
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 07:31:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix seg fault (455 bytes, patch)
2003-12-16 14:31 EST, Jeff Bastian
no flags Details | Diff

  None (edit)
Description Jeff Bastian 2003-12-16 14:30:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031022

Description of problem:
I'm experimenting with the code path if defining
  USE_BROADCAST=0
in serv_list.c.

I found a bug in line 896 that causes a seg fault if running ypbind
with debugging turned on (-d flag).  
  list->server[i]
should be
  list->server[i].host

Attached is a patch.

Since most people use USE_BROADCAST=1, this probably won't affect many
people, but it is a bug.



Version-Release number of selected component (if applicable):
ypbind-1.12-1

How reproducible:
Always

Steps to Reproduce:
1. Define USE_BROADCAST=0 and compile ypbind
2. Start ypbind with -d flag for debugging
3. A child process will seg fault
    

Actual Results:  seg fault

Expected Results:  daemon continues to run

Additional info:
Comment 1 Jeff Bastian 2003-12-16 14:31:38 EST
Created attachment 96565 [details]
patch to fix seg fault

Note You need to log in before you can comment on or make changes to this bug.