Bug 1122693 - Rubygem-Staypuft: Deployment of nonHA Nova with qpid fails on 60% installing the compute.
Summary: Rubygem-Staypuft: Deployment of nonHA Nova with qpid fails on 60% installing...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: unspecified
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: Installer
Assignee: Jason Guiditta
QA Contact: Ami Jeain
URL:
Whiteboard:
: 1126194 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 19:25 UTC by Alexander Chuzhoy
Modified: 2014-08-21 18:06 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:06:08 UTC


Attachments (Terms of Use)
/var/log/messages file from the compute node. (160.93 KB, text/plain)
2014-07-23 19:29 UTC, Alexander Chuzhoy
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Alexander Chuzhoy 2014-07-23 19:25:03 UTC
Rubygem-Staypuft:  Deployment of nonHA Nova with qpid fails on 60% installing the compute.

Environment: liveCD rhelosp-installer-live-6.5-20140722.0.iso
rhel-osp-installer-0.1.4-1.el6ost.noarch
openstack-puppet-modules-2014.1-19.1.el6ost.noarch
openstack-foreman-installer-2.0.16-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch

Steps to reproduce:
1. Boot the liveCD and run the rhel-osp-installer
2. Configure/run a deployment of nonHA Nova network (1 controller +1 compute) with NFS driver backend and qpid messaging provider.

Result:
The deployment gets stuck installing the compute node.
Attempt to run the puppet agent manually on the compute node results with the following:
Info: Applying configuration version '1406142126'
Notice: /Stage[main]/Nova::Compute::Libvirt/Service[messagebus]/ensure: ensure changed 'stopped' to 'running'
Info: /Stage[main]/Nova::Compute::Libvirt/Service[messagebus]: Unscheduling refresh on Service[messagebus]


Error: Could not start Service[nova-compute]: Execution of '/usr/bin/systemctl start openstack-nova-compute' returned 1: Job for openstack-nova-compute.service failed. See 'systemctl status openstack-nova-compute.service' and 'journalctl -xn' for details.
Wrapped exception:
Execution of '/usr/bin/systemctl start openstack-nova-compute' returned 1: Job for openstack-nova-compute.service failed. See 'systemctl status openstack-nova-compute.service' and 'journalctl -xn' for details.
Error: /Stage[main]/Nova::Compute/Nova::Generic_service[compute]/Service[nova-compute]/ensure: change from stopped to running failed: Could not start Service[nova-compute]: Execution of '/usr/bin/systemctl start openstack-nova-compute' returned 1: Job for openstack-nova-compute.service failed. See 'systemctl status openstack-nova-compute.service' and 'journalctl -xn' for details.
Error: Could not start Service[nova-network]: Execution of '/usr/bin/systemctl start openstack-nova-network' returned 1: Job for openstack-nova-network.service failed. See 'systemctl status openstack-nova-network.service' and 'journalctl -xn' for details.
Wrapped exception:
Execution of '/usr/bin/systemctl start openstack-nova-network' returned 1: Job for openstack-nova-network.service failed. See 'systemctl status openstack-nova-network.service' and 'journalctl -xn' for details.
Error: /Stage[main]/Nova::Network/Nova::Generic_service[network]/Service[nova-network]/ensure: change from stopped to running failed: Could not start Service[nova-network]: Execution of '/usr/bin/systemctl start openstack-nova-network' returned 1: Job for openstack-nova-network.service failed. See 'systemctl status openstack-nova-network.service' and 'journalctl -xn' for details.
Notice: /Stage[main]/Nova/Exec[networking-refresh]: Dependency Service[nova-network] has failures: true
Notice: /Stage[main]/Nova/Exec[networking-refresh]: Dependency Service[nova-compute] has failures: true
Warning: /Stage[main]/Nova/Exec[networking-refresh]: Skipping because of failed dependencies
Notice: Finished catalog run in 176.67 seconds


Expected result: the deployment has to pass 100%.

Comment 1 Alexander Chuzhoy 2014-07-23 19:29:09 UTC
Created attachment 920346 [details]
/var/log/messages file from the compute node.

Comment 3 Jason Guiditta 2014-07-23 20:54:22 UTC
Alexander, can you get 'systemctl status openstack-nova-network.service' and 'journalctl -xn' as suggested in the attached messages?

Comment 5 Mike Burns 2014-08-12 18:51:35 UTC
This has worked on deployments since it was filed, marking testonly.

Comment 6 Mike Burns 2014-08-12 19:25:45 UTC
*** Bug 1126194 has been marked as a duplicate of this bug. ***

Comment 7 Alexander Chuzhoy 2014-08-12 20:00:03 UTC
Verified:rhel-osp-installer-0.1.9-1.el6ost.noarch


The deployment completed successfully.

Comment 8 Don Domingo 2014-08-20 04:26:58 UTC
Cleaering requires_doc_text flag. 

(In reply to Mike Burns from comment #5)
> This has worked on deployments since it was filed, marking testonly.

Comment 9 errata-xmlrpc 2014-08-21 18:06:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.