Bug 1122737 - idm_register snippet breaks RHEL 7
Summary: idm_register snippet breaks RHEL 7
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 00:08 UTC by Jason Montleon
Modified: 2016-04-22 15:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:18:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6799 None None None 2016-04-22 15:06:57 UTC

Description Jason Montleon 2014-07-24 00:08:41 UTC
Description of problem:
Using a kickstart with idm_register snippet for RHEL 7 causes the host to hang for about 20 minutes after hitting "Welcome to Red Hat Enterprise Linux 7.0 (Maipo)! 

The snippet seems to be doing a lot more than the freeipa_register snippet, which is fulfilling a similar purpose, though the freeipa_register snippet is quite a bit smaller and doesn't break the RHEL 7 install.

Version-Release number of selected component (if applicable):
Satellite 6.0.3 Beta
ruby193-rubygem-katello-1.5.0-65.el6sat.noarch

How reproducible:
Always, I had several failures while trying to figure out what was going wrong. Eventually getting rid of the idm_register snippet fixed the problem. Adding freeipa_register did not cause any issues and did what was expected

Steps to Reproduce:
1. Install Satellite 6 Beta
2. Try to provision a RHEL 7 system using the idm_register snippet to register to an IPA server

Actual results:
System has a very long delay in boot after hitting Welcome to Red Hat Enterprise Linux 7.0 (Maipo)! message in the boot process.

Expected results:
System boots normally.

Additional info:
idm_register snippet does work fine with RHEL 6.5, but so does the freeipa_register snippet.

Comment 1 RHEL Product and Program Management 2014-07-24 00:13:37 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-07-24 11:06:54 UTC
idm_register looks like something in Katello.  I don't know why it exists separately to freeipa_register.

Comment 4 Stephen Benjamin 2014-07-24 12:58:55 UTC
It's separate because customers should see "FreeIPA" as little as possible -- they should see the downstream name.

I'll take a look, freeipa_snippet may be smaller in Satellite because you have the old one.  Upstream snippet is the same as idm_register, just with different branding.

It wasn't freezing in 6.0.3, QE tested idm_register on RHEL 7.  I'll check, maybe I made a mistake when I applied the branding again.

Comment 5 Jason Montleon 2014-07-24 13:03:44 UTC
I am seeing the issue using 6.0.3 beta.

Comment 6 Dominic Cleal 2014-07-24 13:18:59 UTC
Internals shouldn't be changed for branding, and if it was to be changed then it should have been renamed within Foreman, not duplicated into Katello.

Anyway, leaving untriaged for now until more debugging's done.

Comment 7 Stephen Benjamin 2014-07-24 17:27:58 UTC
@Dominic - I asked Bryan what to do when I solved 1092615, and this is what he said to do.  It's not relevant to this BZ anyway, if you want it changed, file another one and I'll fix it.

Comment 8 Stephen Benjamin 2014-07-28 16:56:08 UTC
Created redmine issue http://projects.theforeman.org/issues/6799 from this bug

Comment 9 Bryan Kearney 2014-08-06 10:04:11 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6799 has been closed

Comment 13 Kedar Bidarkar 2014-08-19 20:31:40 UTC
Tested with Sat6-GA-snap5

idm_register snippet now has the above fix as per comment11 MR.

Also provisioned a RHEL7 machine and verified, there is no delay in the initial boot process.


Installed Packages

    candlepin-0.9.23-1.el6_5.noarch
    candlepin-common-1.0.1-1.el6_5.noarch
    candlepin-scl-1-5.el6_4.noarch
    candlepin-scl-quartz-2.1.5-5.el6_4.noarch
    candlepin-scl-rhino-1.7R3-1.el6_4.noarch
    candlepin-scl-runtime-1-5.el6_4.noarch
    candlepin-selinux-0.9.23-1.el6_5.noarch
    candlepin-tomcat6-0.9.23-1.el6_5.noarch
    createrepo-0.9.9-21.2.pulp.el6sat.noarch
    elasticsearch-0.90.10-4.el6sat.noarch
    katello-1.5.0-28.el6sat.noarch
    katello-ca-1.0-1.noarch
    katello-certs-tools-1.5.6-1.el6sat.noarch
    katello-installer-0.0.59-1.el6sat.noarch
    m2crypto-0.21.1.pulp-10.el6sat.x86_64
    mod_wsgi-3.4-1.pulp.el6sat.x86_64
    pulp-katello-0.3-3.el6sat.noarch
    pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
    pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
    pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
    pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
    pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
    pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
    pulp-server-2.4.0-0.30.beta.el6sat.noarch
    python-gofer-qpid-1.3.0-1.el6sat.noarch
    python-isodate-0.5.0-1.pulp.el6sat.noarch
    python-kombu-3.0.15-12.pulp.el6sat.noarch
    python-pulp-bindings-2.4.0-0.30.beta.el6sat.noarch
    python-pulp-common-2.4.0-0.30.beta.el6sat.noarch
    python-pulp-puppet-common-2.4.0-0.30.beta.el6sat.noarch
    python-pulp-rpm-common-2.4.0-0.30.beta.el6sat.noarch
    python-qpid-0.22-14.el6sat.noarch
    python-qpid-qmf-0.22-37.el6.x86_64
    qpid-cpp-client-0.22-42.el6.x86_64
    qpid-cpp-server-0.22-42.el6.x86_64
    qpid-cpp-server-linearstore-0.22-42.el6.x86_64
    qpid-java-client-0.22-6.el6.noarch
    qpid-java-common-0.22-6.el6.noarch
    qpid-proton-c-0.7-1.el6.x86_64
    qpid-qmf-0.22-37.el6.x86_64
    qpid-tools-0.22-12.el6.noarch
    ruby193-rubygem-katello-1.5.0-82.el6sat.noarch
    rubygem-hammer_cli_katello-0.0.4-12.el6sat.noarch
    rubygem-smart_proxy_pulp-1.0.0-1.1.el6sat.noarch

Comment 16 Bryan Kearney 2014-09-11 12:18:47 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.