Bug 1122785 - [ALL_LANG] [Horizon] "Current Project" is unlocalized
Summary: [ALL_LANG] [Horizon] "Current Project" is unlocalized
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: z3
: 5.0 (RHEL 7)
Assignee: Julie Pichon
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 05:16 UTC by Yuko Katabami
Modified: 2015-02-15 22:02 UTC (History)
6 users (show)

Fixed In Version: python-django-horizon-2014.1.3-2.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-02 15:13:31 UTC


Attachments (Terms of Use)
unlocalized dropdown list "Current Project" (74.06 KB, image/png)
2014-07-24 05:16 UTC, Yuko Katabami
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1929 normal SHIPPED_LIVE python-django-horizon bug fix update 2014-12-02 20:12:30 UTC

Description Yuko Katabami 2014-07-24 05:16:18 UTC
Created attachment 920439 [details]
unlocalized dropdown list "Current Project"

Description of problem:
Drop-down list "Current Project" appears unlocalized in UI.


Version-Release number of selected component (if applicable): 5.0


How reproducible: 100%


Steps to Reproduce:
1.Login to dashboard
2.Change the localze setting to Japanese
3.Check the "Current Project" dropdown list on the top right.

Actual results:
Unlocalized

Expected results:
Should be localized to "現在のプロジェクト"

Additional info:
Screenshot attached.
Confirmed on the upstream UI localization project that this string has been translated.

Comment 2 Yuko Katabami 2014-07-24 05:39:53 UTC
Just realized that this is applicable to all languages. Changed the summary accordingly.

Comment 3 Yuko Katabami 2014-07-24 22:40:49 UTC
Just checked the upstream version of Horizon Icehouse and found that "Current Project" label is no longer applied to the drop down menu to select a project.
It is located at the top left of the screen.

In Havana, it used to be on the left panel, and had "Current Project" label.

Comment 4 Julie Pichon 2014-07-29 08:49:21 UTC
You are correct, it looks like the "Current Project" string was removed with the switch to the new navigation/style so it's not available in the upstream po files anymore.

I wonder if we could work around this with a small downstream patch that contains the extra translation(s) we need. I need to check at what stage the mo files are compiled to see if that would be feasible.

Comment 5 Julie Pichon 2014-09-12 06:40:23 UTC
Investigating with Matthias different ways to approach storing additional downstream strings. There's a few options:
 - Carry a patch (possibly after rebuilding the catalogue to include our strings first) + recompile the messages catalogue downstream,
 - Have a separate catalogue for downstream strings + recompile the messages catalogues downstream (this would be ideal),
 - For this specific bug, since it's so small and while looking for a more comprehensive solution, we could possibly tweak the wording to match upstream so the existing translations get picked up.

Comment 6 Julie Pichon 2014-10-10 13:37:11 UTC
Storing additional message catalogues under the /theme/ app directory with only our downstream strings appears to be working fine, which is great.

We'll need to add an extra step in the build process to make sure the strings are compiled correctly, something along the lines of:

$ cd /usr/share/openstack-dashboard/openstack_dashboard/dashboards/theme
$ django-admin compilemessages

(Calling it from the openstack_dashboard top-level directory doesn't work.)


I don't see any easy way yet to find out which strings are downstream only though, so we will have to rely on the manual efforts of the localisation/internationalisation team a little bit longer. Trying to build the messages catalogue from the theme directory is misleading, because we have a lot of duplicate strings from the horizon message catalogue that are actually translated already that show up in there too.

Comment 7 Julie Pichon 2014-10-10 13:39:25 UTC
How to test:
------------

1. Log in to the dashboard
2. Go to Settings and change the language to "Japanese"
3. Go back to the overview: on the top bar toward the right, "Current project" should be displayed correctly in Japanese (現在のプロジェクト) just before the project name.

Comment 12 errata-xmlrpc 2014-12-02 15:13:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1929.html


Note You need to log in before you can comment on or make changes to this bug.