Bug 1122787 - An error message "Memory Error" displayed on RHEL6.5-i386 when test the Emulex 40G CNA card
Summary: An error message "Memory Error" displayed on RHEL6.5-i386 when test the Emule...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 1.6.5
Hardware: i686
OS: Linux
urgent
urgent
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 05:52 UTC by garrickyang
Modified: 2014-09-15 21:03 UTC (History)
6 users (show)

Fixed In Version: hwcert-client 1.6.5.2-20140902
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-15 21:03:17 UTC


Attachments (Terms of Use)
log (56.82 KB, application/gzip)
2014-07-24 05:53 UTC, garrickyang
no flags Details
error screenshot (502.38 KB, image/png)
2014-07-24 05:53 UTC, garrickyang
no flags Details
test process (11.17 KB, text/plain)
2014-07-24 05:54 UTC, garrickyang
no flags Details
result.xml (1.33 MB, text/xml)
2014-08-01 04:45 UTC, garrickyang
no flags Details
memory-log (40.23 KB, text/plain)
2014-08-13 06:09 UTC, garrickyang
no flags Details
memory-result.xml (1.38 MB, text/xml)
2014-08-13 06:15 UTC, garrickyang
no flags Details
40g-nic-log (9.02 KB, text/plain)
2014-08-13 06:19 UTC, garrickyang
no flags Details
40g-nic-result.xml (1.33 MB, text/xml)
2014-08-13 06:30 UTC, garrickyang
no flags Details
patch limiting http transfer file size on i386 (1.90 KB, patch)
2014-08-21 16:22 UTC, Greg Nichols
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1197 normal SHIPPED_LIVE hwcert-client-1.6.5 bug fix update 2014-09-16 01:02:55 UTC

Description garrickyang 2014-07-24 05:52:30 UTC
Description of problem:

An error message "Memory Error" displayed on RHEL6.5-X86 when test the Emulex 40G CNA card Nic function(UMC enable).

Version-Release number of selected component (if applicable):

hwcert-client-1.6.5.2-20140611

How reproducible:

Test the NIC function of the Emulex 40G CNA card with UMC enable

Actual results:

An error message "Memory Error" displayed on RHEL6.5-X86.

Expected results:

The test should pass.

Additional info:

The NIC function of the Emulex 40G CNA card with UMC enable can be passed on RHEL6.5-X64 and RHEL7.

Comment 1 garrickyang 2014-07-24 05:53:01 UTC
Created attachment 920441 [details]
log

Comment 2 garrickyang 2014-07-24 05:53:38 UTC
Created attachment 920442 [details]
error screenshot

Comment 3 garrickyang 2014-07-24 05:54:17 UTC
Created attachment 920443 [details]
test process

Comment 4 Greg Nichols 2014-07-31 15:46:08 UTC
Please attach the test results with the memory error, either a log, or /var/hwcert/results.xml

Thanks!

Comment 5 garrickyang 2014-08-01 04:45:44 UTC
Created attachment 923080 [details]
result.xml

Comment 6 garrickyang 2014-08-05 01:48:03 UTC
/var/hwcert/results.xml has been submitted. Please help to check and solve the issue as soon as possible.

Thanks!

Comment 8 Greg Nichols 2014-08-12 13:06:49 UTC
Please run the memory test and attach the results.   You can use:

>hwcert-backend run --test memory --debug high

Thanks!
- Greg

Comment 9 Greg Nichols 2014-08-12 13:10:09 UTC
Also, I'm not sure how the trace-back was produced.  Does it happen if only one of the interfaces is tested, ala:

>hwcert-backend run --device eth3 --debug high

Comment 10 garrickyang 2014-08-13 06:09:39 UTC
Created attachment 926273 [details]
memory-log

Comment 11 garrickyang 2014-08-13 06:15:05 UTC
Created attachment 926276 [details]
memory-result.xml

Comment 12 garrickyang 2014-08-13 06:19:35 UTC
Created attachment 926277 [details]
40g-nic-log

Comment 13 garrickyang 2014-08-13 06:30:55 UTC
Created attachment 926279 [details]
40g-nic-result.xml

Comment 14 garrickyang 2014-08-13 07:05:21 UTC
Test only one of the interfaces, it would happen.

The test process interruptted when "Subtest: HTTP -HTTP file transfer test" displayed. And then use the command "hwcert-backend print", it displayed "Error: hwcert is already running(lock file /var/lock/subsys/hwcert found)" .
The phenomenon also appeared with the UMC function disabled.

Comment 15 Greg Nichols 2014-08-15 17:00:24 UTC
What is the size of the file /var/www/html/httptest.file  after the test runs?

Comment 16 garrickyang 2014-08-18 06:39:57 UTC
The size of the file /var/www/html/httptest.file is 625.0MB after the test runs .

Comment 17 garrickyang 2014-08-20 13:12:09 UTC
Hi Greg,

For this bug, we have below 2 items to double confirm, I would be appreciate if you coulg give the feedback ASAP, thanks in advance.

1. As this bug does not occur on RHEL 6.5 x64 and RHEL 7 x64, we want to know if it is due to rhel 6.5 cert tool? 
2. We need to know if it can be resolved before 08/29 once it is a tool issue? As this bug will be block our Grantly system to be on the market on schedule.

Thanks,
Amy

Comment 19 Greg Nichols 2014-08-21 16:05:26 UTC
I suspect that the size of the encoded test file (around 845MB) is pushing i386 process memory limits.

Could you try editing the file /usr/share/hwcert/lib/hwcert/newtworkTest.py,
line 328:

count = self.interfaceSpeed/8

change it to:

count = 2000

And rerun the test.

This should cut the size of the tranfered file down to 340MB or so.

Thanks!

Comment 20 Greg Nichols 2014-08-21 16:22:10 UTC
Created attachment 929260 [details]
patch limiting http transfer file size on i386

Comment 21 garrickyang 2014-08-26 05:40:05 UTC
Hi 

After editing the file /usr/share/hwcert/lib/hwcert/newtworkTest.py, the NIC test can pass, but the info failed for the editing, please update the test suite as soon as possible. As this issue will be block our Grantly system to be on the market on schedule.

Thanks

Comment 24 garrickyang 2014-09-05 09:31:25 UTC
Hi,

After editing the file /usr/share/hwcert/lib/hwcert/newtworkTest.py, the NIC test can pass, but the "info test" failed for editing .py file, please help to solve the problem and update the test suite as soon as possible. As this issue will  block our Grantly system to be on the market on schedule.

Comment 26 garrickyang 2014-09-09 02:33:35 UTC
After modifying count = 2000 , the result has passed.

Comment 29 errata-xmlrpc 2014-09-15 21:03:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1197.html


Note You need to log in before you can comment on or make changes to this bug.