Bug 1122807 - [RFE] Log a checksum of the new client volfile after a graph change.
Summary: [RFE] Log a checksum of the new client volfile after a graph change.
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 06:53 UTC by Joe Julian
Modified: 2019-04-27 17:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-27 17:17:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Joe Julian 2014-07-24 06:53:52 UTC
Description of problem:

There's no way to know if a client failed to retrieve its new vol file after a graph change. If there was a sha1sum some other consistent checksum, we could easily check all our client logs to ensure the change was completed.

Comment 1 Gaurav Kumar Garg 2014-12-22 12:17:42 UTC
Joe,
you can easily check the checksum in client log. but what if you dont have permission in storage node to see actual checksum of volfile.

Regards
Gaurav

Comment 2 Joe Julian 2014-12-22 16:24:05 UTC
Since any user that can mount a volume will have access to that volume's log file, that should be sufficient. Typically this will only be used for diagnostics or monitoring with root access anyway.

Perhaps a future enhancement could add that to "volume status client"  but this should be sufficient for now.

Comment 3 Yaniv Kaul 2019-04-27 17:17:50 UTC
Closing for the time being due to lack of priority and resources to implement.


Note You need to log in before you can comment on or make changes to this bug.