Bug 1122814 - [RFE] Provide more examples to use with REST API
Summary: [RFE] Provide more examples to use with REST API
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Deadline: 2015-10-21
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs API Guide
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: David O'Brien
QA Contact: Stephen Wadeley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 07:19 UTC by jnikolak
Modified: 2018-12-06 17:27 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-17 17:34:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1067105 None None None 2019-08-06 20:28:13 UTC
Red Hat Knowledge Base (Solution) 1140893 None None None Never
Red Hat Bugzilla 1209202 None None None 2019-08-06 20:28:13 UTC

Internal Links: 1067105 1209202

Description jnikolak 2014-07-24 07:19:28 UTC
Description of problem:

OK, I've figured out what was wrong with my search string.  It was a case of knowing where to put = and ? characters.  

It would be handy if the documentation had examples of URLs used to query the REST API.  It's not very obvious from the documentation.  The various parameters are covered in great depth, but not how to build the URLs.


Using the documentation found here:
--> https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/pdf/API_Guide/Red_Hat_Satellite-6.0-API_Guide-en-US.pdf

Comment 1 RHEL Product and Program Management 2014-07-24 07:44:02 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Athene Chan 2014-07-24 22:08:08 UTC
Hello,

Thank you for your feedback. We'll scope out this request and evaluate whether we can fit this request into GA or post-GA documentation. I am assigning this to David, one of our Satellite writers for evaluation.

Should you notice other areas of concern, please let us know! Your feedback helps make the docs better!

Cheers,
Athene

Comment 5 Xixi 2014-07-29 12:42:20 UTC
Seems a extension or possible duplicate of Bug 1067105 "[RFE] Satellite 6: Add more examples of how to use/script Satellite APIs in documentation", with Python and Ruby examples in https://bugzilla.redhat.com/show_bug.cgi?id=1067105#c2

Comment 7 Mark Huth 2014-08-05 00:54:53 UTC
Created KCS article https://access.redhat.com/solutions/1140893 with some examples of searching the Sat6 API using curl and python.  HTH.

Comment 12 David O'Brien 2015-10-13 02:39:45 UTC
https://access.redhat.com/solutions/1140893

Fixed curl examples that were using the wrong switches and http instead of https.

Docs topic is ongoing.

Comment 16 David O'Brien 2015-10-19 02:30:04 UTC
Setting deadline 21st for tech review to make sure I have time to integrate this and other API bugs.

Comment 18 David O'Brien 2015-10-21 21:15:04 UTC
Thanks Brad.

Will merge this with master and send to QA.


Note You need to log in before you can comment on or make changes to this bug.