Bug 1122826 - NetworkManager crashes when setting hostname and SELinux is disabled
Summary: NetworkManager crashes when setting hostname and SELinux is disabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jirka Klimes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 07:43 UTC by Marc Muehlfeld
Modified: 2019-05-20 11:14 UTC (History)
8 users (show)

Fixed In Version: NetworkManager-0.9.9.1-30.git20140326.4dba720.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 13:52:24 UTC


Attachments (Terms of Use)
Traceback and Memory map from /var/log/messages (33.26 KB, text/plain)
2014-07-24 07:43 UTC, Marc Muehlfeld
no flags Details
[PATCH] Patch fixing the crash (1.60 KB, patch)
2014-07-24 12:59 UTC, Jirka Klimes
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0311 normal SHIPPED_LIVE NetworkManager bug fix and enhancement update 2015-03-05 17:35:10 UTC
CentOS 7424 None None None Never

Description Marc Muehlfeld 2014-07-24 07:43:52 UTC
Created attachment 920458 [details]
Traceback and Memory map from /var/log/messages

Description of problem:
If SELinux is disabled, nmtui crashes, when you try to set/change the hostname.



Version-Release number of selected component (if applicable):
* NetworkManager-0.9.9.1-25.git20140326.4dba720



How reproducible:
* Always



Steps to Reproduce:
1. Disable SELinux in /etc/sysconfig/selinux
2. Reboot
3. Check with "sestatus", that it's really disabled
4. Run "nmtui"
5. Choose "Set system hostname"
6. Type in a hostname, like "xxx.yyy" and hit OK



Actual results:
* Application freezes.
* NetworkManager process crashes (/var/log/messages): *** Error in `/usr/sbin/NetworkManager': free(): invalid pointer: 0x00007fa24ae35240 ***



Expected results:
* Hostname should be set and application should return back to prompt.



Additional info:
* If you re-enable SELinux in /etc/sysconfig/selinux and reboot, setting the hostname in nmtui is possible again.
* I discovered this problem in CentOS7, but I think it's a bug directly in RHEL7.

Comment 2 Jirka Klimes 2014-07-24 12:55:41 UTC
Thanks for the report. I can reproduce the crash on latest RHEL7.

The problem is not in nmtui, but in NM ifcfg-rh plugin. When SELinux is disabled SELinux, getfscreatecon() fails and we tried to free uninitialized context later.

Testcase:
1) Enable ifcfg-rh plugin in /etc/NetworkManger/NetworkManger.conf
   plugins=ifcfg-rh
2) Edit /etc/sysconfig/selinux to contain
   SELINUX=disabled
3) Reboot
4) Set hostname via nmcli, nmtui or D-Bus SaveHostname() call
   nmcli gen hostname this-is-my-pc
5) NM crashes

Comment 3 Jirka Klimes 2014-07-24 12:59:00 UTC
Created attachment 920529 [details]
[PATCH] Patch fixing the crash

This patch fixes the crash in ifcfg-rh.

Comment 5 Dan Winship 2014-07-24 14:19:48 UTC
yeah, looks right

Comment 6 Jirka Klimes 2014-07-25 07:52:37 UTC
Committed upstream:
93f7fa9 ifcfg-rh: fix a crash on setting hostname with SELinux disabled (rh #1122826)

Comment 10 errata-xmlrpc 2015-03-05 13:52:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0311.html


Note You need to log in before you can comment on or make changes to this bug.