Bug 1122834 - Issues reported by Coverity static analysis tool
Summary: Issues reported by Coverity static analysis tool
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: 3.6.0
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 07:58 UTC by Xavi Hernandez
Modified: 2014-11-11 08:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 789278
Environment:
Last Closed: 2014-11-11 08:37:11 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2014-07-24 07:58:04 UTC
+++ This bug was initially created as a clone of Bug #789278 +++

Comment 1 Anand Avati 2014-07-24 08:13:20 UTC
REVIEW: http://review.gluster.org/8372 (ec: Fixed coveriry scan issues) posted (#1) for review on release-3.6 by Xavier Hernandez (xhernandez@datalab.es)

Comment 2 Anand Avati 2014-07-28 07:21:43 UTC
REVIEW: http://review.gluster.org/8372 (ec: Fixed coverity scan issues) posted (#2) for review on release-3.6 by Xavier Hernandez (xhernandez@datalab.es)

Comment 3 Anand Avati 2014-08-03 14:53:35 UTC
COMMIT: http://review.gluster.org/8372 committed in release-3.6 by Vijay Bellur (vbellur@redhat.com) 
------
commit b0f2326bbf2127792a4dc090785948d55c53b6e5
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Wed Jul 16 13:50:53 2014 +0200

    ec: Fixed coverity scan issues
    
    CID list:
    
      1226163 Logically dead code
      1226166 Missing break in switch
      1226167 Missing break in switch
      1226168 Missing break in switch
      1226169 Missing break in switch
      1226170 Missing break in switch
      1226171 Missing break in switch
      1226172 Missing break in switch
      1226173 Missing break in switch
      1226174 Missing break in switch
      1226175 Missing break in switch
      1226176 Missing break in switch
      1226177 Missing break in switch
      1226178 Data race condition
      1226179 Data race condition
      1226180 Data race condition
      1226181 Thread deadlock
      1226182 Uninitialized pointer read
      1226183 Uninitialized pointer read
      1226184 Read from pointer after free
    
    Change-Id: I4d33aa42289371927175c43bb29e018df64fb943
    BUG: 1122834
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/8372
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 4 Niels de Vos 2014-11-11 08:37:11 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users


Note You need to log in before you can comment on or make changes to this bug.