Bug 1122842 - Vague language and possible typo in Hard Drive installation instructions
Summary: Vague language and possible typo in Hard Drive installation instructions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-docs
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karsten Wade
QA Contact: Tammy Fox
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 08:13 UTC by Hedayat Vatankhah
Modified: 2015-05-29 15:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-29 15:34:40 UTC


Attachments (Terms of Use)

Description Hedayat Vatankhah 2014-07-24 08:13:01 UTC
Description of problem:
There are two sections which are talking about Hard Drive installation:

1. http://docs.fedoraproject.org/en-US/Fedora/20/html/Installation_Guide/ch-Installation_Phase_2-x86.html#s1-begininstall-hd-x86

In this link, "linux repo=" option is introduced like this:
linux repo=hd:device

Later it says that the path of ISO files should be specified, but it is not clear that 'how' you can specify the path of the ISO files. (the main pattern doesn't include path its just "hd:device"). AFAIK, the above option should be introduced as:
linux repo=hd:device:path

2. http://docs.fedoraproject.org/en-US/Fedora/20/html/Installation_Guide/ap-admin-options.html
The "inst.repo=" for HDD installation is specified as:
 inst.repo=hd:device/path

I don't remember if I've tried "inst.repo=" option, but "repo=" option doesn't work as "repo=hd:device/path" but works with a colon between device and path; e.g. "repo=hd:device:path". This is what I've used to successfully boot Fedora 20's installer (I have specified .iso file but according to the documentation it should not be needed. Anyway, this worked for me):

linux /boot/vmlinuz-20 repo=hd:/dev/sda8:/tmp/Fedora-20-x86_64-DVD.iso

Comment 1 Fedora End Of Life 2015-05-29 12:27:29 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 2 Hedayat Vatankhah 2015-05-29 15:34:40 UTC
Seems to be fixed in F22 guide.


Note You need to log in before you can comment on or make changes to this bug.