Bug 1122868 - landscape printing in writer is broken
Summary: landscape printing in writer is broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 09:11 UTC by Arnaud
Modified: 2014-08-07 15:28 UTC (History)
10 users (show)

Fixed In Version: libreoffice-4.2.6.2-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-07 15:28:42 UTC


Attachments (Terms of Use)

Description Arnaud 2014-07-24 09:11:38 UTC
Description of problem:
The landscape is broken, and when I print they are printed some pages are printed in portrait and others in landscape.

If I install libreoffice 4.2.5.2-2, I don't have this problem, so it is a change in 4.2.5.2-3 that seems to break it (possibly the fdo#80911: toggle fallback paper sizes when they are already in landscape mode), because if I install 4.2.5.2-3 the problem reappears.

Version-Release number of selected component (if applicable):
libreoffice-4.2.5.2-6.fc20.x86_64
libreoffice-core-4.2.5.2-6.fc20.x86_64
libreoffice-writer-4.2.5.2-6.fc20.x86_64

How reproducible:
always

Steps to Reproduce:
1. open writer, put the pages in landscape
2. add some text, [ctrl][enter], add some text in the 2nd page
3. try to print, in preview in the left, switch pages (back and forth

Actual results:
When you switch in the preview:
Page 1: landscape
Page 2: landscape
then back to Page 1: portrait

When you print, not all pages are in landscape

Expected results:
All pages are printed in landscape if they are all in landscape

Comment 1 Arnaud 2014-07-24 09:40:13 UTC
It does that problem portrait/landscape too in calc, for the same versions.
4.2.5.2-2 doesn't do it, but 4.2.5.2-3 does it.

(I had deleted the openoffice profil for the user)

Comment 2 Caolan McNamara 2014-07-24 15:35:09 UTC
rats

Comment 3 Jim 2014-07-26 01:22:34 UTC
Just updated to libreoffice-4.2.5.2-9.fc20 and found problem still exists.

Printing 2 page landscape document on Brother HL5340D in duplex. Sometimes page 1 is portrait, sometimes page 2.
Little preview in print window also inconsistent, sometimes shows portrait sometimes landscape.
Tested again after removing ~/.config/libreoffice but same result.

Comment 4 Fedora Update System 2014-07-26 13:34:18 UTC
libreoffice-4.2.5.2-11.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreoffice-4.2.5.2-11.fc20

Comment 5 David W. Legg 2014-07-26 18:41:40 UTC
Thanks, chaps; really appreciate this fix.

Comment 6 Arnaud 2014-07-27 03:05:56 UTC
Thanks, it fixes it for me too.

Comment 7 Fedora Update System 2014-07-28 03:24:24 UTC
Package libreoffice-4.2.5.2-11.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-4.2.5.2-11.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8913/libreoffice-4.2.5.2-11.fc20
then log in and leave karma (feedback).

Comment 8 Jim 2014-07-29 03:34:40 UTC
libreoffice-4.2.5.2-11.fc20 fixes it for me, thanks everyone

karma given

Comment 9 Fedora Update System 2014-07-29 14:24:23 UTC
libreoffice-4.2.6.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreoffice-4.2.6.2-1.fc20

Comment 10 Jim 2014-07-31 02:34:47 UTC
libreoffice-4.2.6.2-1.fc20 works for me

Comment 11 Fedora Update System 2014-08-07 15:28:42 UTC
libreoffice-4.2.6.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.