Bug 1122875 - Multi-JSF feature ignore's original modules if custom one is added
Summary: Multi-JSF feature ignore's original modules if custom one is added
Keywords:
Status: CLOSED DUPLICATE of bug 1054051
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: JSF
Version: 6.2.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Farah Juma
QA Contact: Marek Schmidt
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 09:29 UTC by Jonáš Trantina
Modified: 2014-07-24 13:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-24 13:57:08 UTC
Type: Bug


Attachments (Terms of Use)
example cli file to add new JSF module (2.78 MB, application/octet-stream)
2014-07-24 09:29 UTC, Jonáš Trantina
no flags Details

Description Jonáš Trantina 2014-07-24 09:29:02 UTC
Created attachment 920485 [details]
example cli file to add new JSF module

Description of problem:
When a custom JSF module is added as described here [1]. The original modules (1.2 and main) are no longer available, only the newly added module is available.

The availability of JSF modules is checked via CLI: "/subsystem=jsf:list-active-jsf-impls".

I believe WFLY-976 [2] is the upstream bug- this seems to be fixed in WildFly but not in Jboss AS 7.

[1] https://community.jboss.org/wiki/DesignOfAS7Multi-JSFFeature
[2] https://issues.jboss.org/browse/WFLY-976


To reproduce:
Run the .cli file attached to the case- this adds mojarra 2.2. Restart the server and run "/subsystem=jsf:list-active-jsf-impls" -> only the newly added module is available, both 1.2 and main is no longer there.

Comment 1 Jonáš Trantina 2014-07-24 09:33:18 UTC
The workaround is to copy the original modules from modules/system/layers/base/ to modules/ (that is where the new JSF module is added).
It seems that if a module is found in modules/ then modules/system/layers/base/ is no longer scanned.

Comment 2 Farah Juma 2014-07-24 13:57:08 UTC
This issue duplicates bug 1054051. This has been fixed in EAP 6.3.0.

*** This bug has been marked as a duplicate of bug 1054051 ***


Note You need to log in before you can comment on or make changes to this bug.