Bug 1122885 - qemu-img man doc should tell "should report progress bar when receives "SIGUSR1" signal if -p option is not used"
Summary: qemu-img man doc should tell "should report progress bar when receives "SIGUS...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: ---
Assignee: Max Reitz
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 10:00 UTC by Sibiao Luo
Modified: 2014-10-14 07:02 UTC (History)
12 users (show)

Fixed In Version: qemu-kvm-0.12.1.2-2.437.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 07:02:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1490 normal SHIPPED_LIVE qemu-kvm bug fix and enhancement update 2014-10-14 01:28:27 UTC

Description Sibiao Luo 2014-07-24 10:00:07 UTC
Description of problem:
should display progress bar when "qemu-img convert -p" receives "SIGUSR1" signal, we has fixed this issue for rhel6.2 in bug 621482 and it works for rhel6.6, but the qemu-img man help doc did not high light it for users.
BTW, the rhel7 qemu-img man help doc has it.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm-rhev
2.6.32-492.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.430.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.# man qemu-img | grep 'bar'
       -p  display progress bar (convert and rebase commands only)
2.
3.

Actual results:


Expected results:
       -p  display progress bar (compare, convert and rebase commands only).  If the -p option is not used for a
           command that supports it, the progress is reported when the process receives a "SIGUSR1" signal.

Additional info:
> qemu-img convert -f raw -O qcow2 winxp winxp.qcow2
> send SIGUSR1 every 5s:
    (14.05/100%)
    (16.06/100%)
    (18.07/100%)
    (20.08/100%)
    (22.09/100%)
    (72.28/100%)

Comment 1 Jeff Nelson 2014-08-13 06:41:55 UTC
Fix included in qemu-kvm-0.12.1.2-2.437.el6

Comment 2 Qunfang Zhang 2014-08-13 09:09:13 UTC
Reproduced this bug on qemu-kvm-0.12.1.2-2.430.el6 and verified pass on qemu-kvm-0.12.1.2-2.437.el6.

On qemu-kvm-0.12.1.2-2.430.el6:

# man qemu-img | grep -i bar
       -p  display progress bar (convert and rebase commands only)

# man qemu-img (and then check the "-p" option):
       -p  display progress bar (convert and rebase commands only)


On qemu-kvm-0.12.1.2-2.437.el6:

# man qemu-img (and then check the "-p" option):

       -p  display progress bar (compare, convert and rebase commands only).  If the -p option is not used for a command that supports
           it, the progress is reported when the process receives a "SIGUSR1" signal.

Based on above, the issue is fixed.

Comment 5 errata-xmlrpc 2014-10-14 07:02:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1490.html


Note You need to log in before you can comment on or make changes to this bug.