Bug 1122897 - Blueman isn't included in the currently released dailies and won't run if compiled
Summary: Blueman isn't included in the currently released dailies and won't run if com...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: blueman
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 10:42 UTC by Anthony Name
Modified: 2015-03-01 20:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Fedora 21 Compiz Mate Spin
Last Closed: 2015-03-01 20:01:08 UTC


Attachments (Terms of Use)

Description Anthony Name 2014-07-24 10:42:08 UTC
Description of problem:

Bluetooth support in the Mate-Compiz spin is missing - it's supposed to be supported as part of the Bluez5 migration but isn't there.

Compiling from source against 21 doesn't work with a blueman.Constants module missing error when trying to start blueman-manager.

Version-Release number of selected component (if applicable):

Fedora-F21- Daily releases up to 21st July 2014

How reproducible:

Install Fed21 Compiz Mate spin.....try to use bluetooth.....no app

Compile blueman from git source....blueman.Constants module missing error


Steps to Reproduce:
1.  As described above
2.
3.

Actual results:

No bluetooth


Expected results:

Functional bluetooth


Additional info:

I'm not sure if this is an upstream problem or a packaging problem, but in the Fed21 Mate spin it doesn't seem to currently have a clearly defined owner and therefore may slip through the cracks.

Comment 1 Kalev Lember 2014-07-25 12:14:48 UTC
Sorry, Blueman was dropped from Fedora because it doesn't support the Bluez 5 stack we have. You could try asking upstream if they are willing to update it, but I wouldn't have high hopes -- it seems unmaintained.

In the mean time, you should be able to get proper bluetooth support in GNOME.

Comment 2 Anthony Name 2014-07-25 15:18:56 UTC
Kevin

Upstream is still getting updated and indeed there's a Blueman2 mentioned on the milestones.

https://github.com/blueman-project/blueman

https://github.com/blueman-project/blueman/issues/milestones

However if I've understood you correctly then there will be no support for bluetooth in the Mate Compiz spin unless you install gnome3 which somewhat defeats the point given all the dependencies/bloat that come with that.

It's also mentioned here.....under the Mate section

http://fedoraproject.org/wiki/Changes/Bluez5

That a standalone app was being created for F20 but the source for that seems to have disappeared from the link.

Comment 3 Wolfgang Ulbrich 2014-07-26 09:15:18 UTC
Bluedevil from kde should also work in MATE, which is in secondary mate comps group and is the official replacement for mate-bluetooth in fedora.
Run yum groupinstall 'MATE Applications' .

Mate upstream offer to use new blueman version from github which support bluez5.
But sorry, i don't use bluetooth for myself an i don't have a device for testing it.
For this reason i decided not to bring it in fedora as a package.
Also i maintained the whole mate desktop currently alone in fedora which is enough for me ;)
But maybe the old blueman maintainer has an interest to bring blueman back in fedora.


Note You need to log in before you can comment on or make changes to this bug.