Bug 1122904 - References related sparc, solaris needs to be removed from help text/tips and from error messages
Summary: References related sparc, solaris needs to be removed from help text/tips and...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 11:12 UTC by Sachin Ghai
Modified: 2014-08-11 17:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 17:14:00 UTC


Attachments (Terms of Use)
Hardware Models page includes info related to sparc/solaris (28.81 KB, image/png)
2014-07-24 11:12 UTC, Sachin Ghai
no flags Details
another help text referencing to debian as well (51.60 KB, image/png)
2014-07-24 11:20 UTC, Sachin Ghai
no flags Details

Description Sachin Ghai 2014-07-24 11:12:03 UTC
Created attachment 920503 [details]
Hardware Models page includes info related to sparc/solaris

Description of problem:
In sat6, I saw few instances where some text includes sparc and solaris related info. 

Since we know sat6 doesn't support solaris and sparc platform, so I think we should remove all such references to avoid any confusion.

Version-Release number of selected component (if applicable):
sat6 GA snap1

How reproducible:
always

Steps to Reproduce:
1. Go To Hosts menu --> Hardware Models
Here 'Hardware model' and 'vendor class' help text includes some info related to sparc and solaris. Please see attached screenshot

2. when we create media, without any URL or invalid URL then the error message includes sparc/solaris related info


Actual results:


Expected results:
Since we know sat6 doesn't support solaris and sparc platform, so I think we should remove all such references to avoid any confusion. OR may be we should update the same info with supported OS and arch


Additional info:

Comment 1 Dominic Cleal 2014-07-24 11:13:22 UTC
My understanding was that no functionality was to be removed for unsupported operating systems and architectures.  Please confirm Bryan?

(I believe this is WONTFIX)

Comment 2 RHEL Product and Program Management 2014-07-24 11:13:49 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Sachin Ghai 2014-07-24 11:18:13 UTC
My only suggestion is to just update the help text.. we may keep the functionality for unsupported os/arch. 

I saw some references related to Debian as well.

Comment 5 Sachin Ghai 2014-07-24 11:20:02 UTC
Created attachment 920505 [details]
another help text referencing to debian as well


Note You need to log in before you can comment on or make changes to this bug.