Bug 1122911 - netcdf tests hang on s390(x)
Summary: netcdf tests hang on s390(x)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: netcdf
Version: 20
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker
TreeView+ depends on / blocked
 
Reported: 2014-07-24 11:39 UTC by Jakub Čajka
Modified: 2014-08-01 23:55 UTC (History)
5 users (show)

Fixed In Version: netcdf-4.3.2-4.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-24 15:36:13 UTC


Attachments (Terms of Use)
Patch (1.93 KB, patch)
2014-07-24 11:39 UTC, Jakub Čajka
no flags Details | Diff
Koji build log (589.11 KB, text/x-log)
2014-07-24 11:40 UTC, Jakub Čajka
no flags Details
Nicer patch (1.72 KB, patch)
2014-07-24 12:32 UTC, Jakub Čajka
no flags Details | Diff

Description Jakub Čajka 2014-07-24 11:39:05 UTC
Created attachment 920517 [details]
Patch

Included tests hangs on s390(x) koji. Hang is caused by run_par_tests.sh, disabling parallel tests in spec file(omitting --enable-parallel-tests) enables tests to pass. 

Surprisingly local mock build on s390(x) is successful even with enabled parallel tests, also tests pass on s390, but they hang on s390 koji same way as s390x.

In attachment is patch enabling tests on s390, and disabling parallel tests on s390(x).

Link to scratch build:
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1442576

Link to hanging build:
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1442478

Comment 1 Jakub Čajka 2014-07-24 11:40:28 UTC
Created attachment 920518 [details]
Koji build log

Comment 2 Jakub Čajka 2014-07-24 12:32:55 UTC
Created attachment 920524 [details]
Nicer patch

Comment 3 Orion Poplawski 2014-07-24 15:36:13 UTC
Thanks.  Checked in and building for f22, f21, and el7.

Comment 4 Dan Horák 2014-07-24 15:49:59 UTC
(In reply to Orion Poplawski from comment #3)
> Thanks.  Checked in and building for f22, f21, and el7.

Can you make an update for f20 too? It's what is failing for us now.

Comment 5 Orion Poplawski 2014-07-24 15:58:12 UTC
Checked in and building for f20 too.  Do you need an update, or is that sufficient to build on s390?

Comment 6 Dan Horák 2014-07-24 16:06:44 UTC
With an update, thanks.

Comment 7 Fedora Update System 2014-07-24 17:22:45 UTC
netcdf-4.3.2-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/netcdf-4.3.2-4.fc20

Comment 8 Fedora Update System 2014-08-01 23:55:02 UTC
netcdf-4.3.2-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.