Bug 1122943 - host is up even if it's missing required network.
Summary: host is up even if it's missing required network.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Nobody
QA Contact:
URL:
Whiteboard: network
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 12:57 UTC by Martin Mucha
Modified: 2016-02-10 19:54 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 11:41:45 UTC
oVirt Team: Network


Attachments (Terms of Use)

Description Martin Mucha 2014-07-24 12:57:00 UTC
Description of problem:

I'm not sure if this is a bug, but it seems to be one.



Steps to Reproduce:
1. create host
2. create network
3. in setup host networks assign network
4. in cluster's manage network uncheck assigned and requested.
5. in setup host networks there's unmanaged network, remove it.
6. reenable assigned and required checkboxes for given network in cluster's manage network.

Actual results:
host is up after that

Expected results:
host should be not functional since it does not have required network assigned.

Additional info:

Comment 1 Lior Vernia 2014-07-30 11:41:45 UTC
This sounds like correct behavior - once the network is detached from the cluster and then re-attached, it is principally a new network. A new network, even if it's required, will not render hosts non-operational - instead the network itself will appear as non-operational (red down arrow) until it's configured on all active hosts. Only from that point on specific hosts will move to non-operational state if the network is missing on them.


Note You need to log in before you can comment on or make changes to this bug.