Bug 1122956 - Cannot install amavisd-new in CentOS-7
Summary: Cannot install amavisd-new in CentOS-7
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: amavisd-new
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Morten Stevens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1121606 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 13:17 UTC by Timothy Murphy
Modified: 2014-08-04 14:10 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 21:48:33 UTC


Attachments (Terms of Use)

Description Timothy Murphy 2014-07-24 13:17:52 UTC
Description of problem:
The epel repository contains the amavisd-new package, but is lacking clamav-server, which is required

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. run "sudo yum install amavisd-new"
2.
3.

Actual results:
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: perl(Unix::Syslog)
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: clamav-server
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: clamav-server-systemd
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: cabextract
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: perl(Convert::TNEF)

Expected results:
Installation of amavisd-new

Additional info:

Comment 1 Morten Stevens 2014-07-28 21:48:33 UTC
I've built all necessary dependencies for amavisd-new.

See:

http://koji.fedoraproject.org/koji/buildinfo?buildID=547729
http://koji.fedoraproject.org/koji/buildinfo?buildID=547579
http://koji.fedoraproject.org/koji/buildinfo?buildID=548472
http://koji.fedoraproject.org/koji/buildinfo?buildID=548473

You should be able to install amavisd-new via yum tomorow.

# closed

Comment 2 Timothy Murphy 2014-07-29 14:13:40 UTC
I'm afraid this did not work.

1. amavisd-new requires perl-Unix-Syslog,
which is not in epel.repo but is in rpmforge.repo.

2. However, after installing this "sudo yum install amavisd-new"
brings up the error
-----------------------
Error: Package: clamav-server-systemd-0.98.4-1.el7.noarch (epel)
           Requires: clamav-server = 0.98.4-1.el7
           Available: clamav-server-0.98.4-1.el7.x86_64 (epel)
               clamav-server = 0.98.4-1.el7
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: clamav-server
           Available: clamav-server-0.98.4-1.el7.x86_64 (epel)
               clamav-server = 0.98.4-1.el7
-----------------------

3. Now "sudo yum install clamav-server" brings up the warning
-----------------------
Package clamav-server is obsoleted by clamd, trying to install clamd-0.98.4-1.el7.rf.x86_64 instead
-----------------------

4. Now after clamd is installed, "sudo yum install amavisd-new"
brings up the error
-----------------------
Error: Package: clamav-server-systemd-0.98.4-1.el7.noarch (epel)
           Requires: clamav-server = 0.98.4-1.el7
           Available: clamav-server-0.98.4-1.el7.x86_64 (epel)
               clamav-server = 0.98.4-1.el7
Error: Package: amavisd-new-2.9.1-1.el7.noarch (epel)
           Requires: clamav-server
           Available: clamav-server-0.98.4-1.el7.x86_64 (epel)
               clamav-server = 0.98.4-1.el7
-----------------------
which seems to have taken me in a circle.

Comment 3 Morten Stevens 2014-07-29 14:24:40 UTC
(In reply to Timothy Murphy from comment #2)
> I'm afraid this did not work.

I was able to install amavisd-new without problems.

> 1. amavisd-new requires perl-Unix-Syslog,
> which is not in epel.repo but is in rpmforge.repo.

It is in Fedora-EPEL.
See: http://dl.fedoraproject.org/pub/epel/beta/7/x86_64/

> which seems to have taken me in a circle.

Please remove all rpmforge packages and install it only from EPEL repo. It is not a good idea to mix EPEL and rpmforge packages!

Comment 4 Timothy Murphy 2014-07-29 15:45:05 UTC
Please look more carefully at what I said in (1) above.

The package perl-Unix-Syslog, which amavisd-new required, was not in epel.
I don't like mixing Epel and Rpmforge, and don't have rpmforge.repo enabled, but in this case it appeared necessary to enable it temporarily to get this package.

As to the confusion with clamd/clamav-server, it is possible that the site yum found for me is not up-to-date. I will try again tomorrow, and see if I have better luck.

Comment 5 Paul Howarth 2014-07-29 15:57:01 UTC
(In reply to Timothy Murphy from comment #4)
> Please look more carefully at what I said in (1) above.
> 
> The package perl-Unix-Syslog, which amavisd-new required, was not in epel.
> I don't like mixing Epel and Rpmforge, and don't have rpmforge.repo enabled,
> but in this case it appeared necessary to enable it temporarily to get this
> package.
> 
> As to the confusion with clamd/clamav-server, it is possible that the site
> yum found for me is not up-to-date. I will try again tomorrow, and see if I
> have better luck.

That's probably the case, because perl-Unix-Syslog-1.1-17.el7.x86_64.rpm *is* now in EPEL7, as mentioned by Morten in Comment #2 above.

Comment 6 Valentina Mukhamedzhanova 2014-08-04 12:24:31 UTC
*** Bug 1121606 has been marked as a duplicate of this bug. ***

Comment 7 Timothy Murphy 2014-08-04 14:10:28 UTC
I should have said earlier that I have now yum-installed amavisd-new.
I yum-removed clamav-server, and that solved the problem.


Note You need to log in before you can comment on or make changes to this bug.