Bug 1122959 - [abrt] youtube-dl: utils.py:1013:write_string:IOError: [Errno 5] Input/output error
Summary: [abrt] youtube-dl: utils.py:1013:write_string:IOError: [Errno 5] Input/output...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: youtube-dl
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Till Maas
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:36d40fd3ec9e3a3ba665f293042...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 13:18 UTC by Tobias Brodel
Modified: 2015-02-10 12:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-10 12:52:55 UTC


Attachments (Terms of Use)
File: backtrace (1.58 KB, text/plain)
2014-07-24 13:18 UTC, Tobias Brodel
no flags Details
File: environ (3.00 KB, text/plain)
2014-07-24 13:18 UTC, Tobias Brodel
no flags Details

Description Tobias Brodel 2014-07-24 13:18:36 UTC
Description of problem:
I tried to download a video, it failed the first time and prompted me to run 'youtube-dl -U' to get the lastest version.

I did so as root and repeated the command. Then it failed and ABRT caught the error.

Version-Release number of selected component:
youtube-dl-2014.07.20.2-1.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        python /usr/bin/youtube-dl -f mp4 http://www.youtube.com/watch?v=BQx_2bQniZI
dso_list:       python-libs-2.7.5-13.fc20.x86_64
executable:     /usr/bin/youtube-dl
kernel:         3.15.6-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
utils.py:1013:write_string:IOError: [Errno 5] Input/output error

Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/bin/youtube-dl/__main__.py", line 18, in <module>
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 859, in main
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 849, in _real_main
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 1052, in download
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 527, in extract_info
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 564, in process_ie_result
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 830, in process_video_result
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 1024, in process_info
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 405, in report_error
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 358, in trouble
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 312, in to_stderr
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 291, in _write_string
  File "/usr/bin/youtube-dl/youtube_dl/utils.py", line 1013, in write_string
IOError: [Errno 5] Input/output error

Local variables in innermost frame:
byt: 'ERROR: unable to download video data: The read operation timed out\n'
out: <open file '<stderr>', mode 'w' at 0x7fbc8c3cd1e0>
s: u'ERROR: unable to download video data: The read operation timed out\n'
encoding: None

Comment 1 Tobias Brodel 2014-07-24 13:18:39 UTC
Created attachment 920530 [details]
File: backtrace

Comment 2 Tobias Brodel 2014-07-24 13:18:41 UTC
Created attachment 920531 [details]
File: environ

Comment 3 Fedora Admin XMLRPC Client 2015-02-09 00:16:32 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Till Maas 2015-02-10 12:52:55 UTC
So it was not a bug in the version shipped by Fedora but in the upstream download. However, it seems to be fixed now.


Note You need to log in before you can comment on or make changes to this bug.