Bug 1122968 - neutron/manifests/agents/ovs.pp creates /etc/sysconfig/network-scripts/ifcfg-br-{int,tun}
Summary: neutron/manifests/agents/ovs.pp creates /etc/sysconfig/network-scripts/ifcfg-...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RDO
Classification: Community
Component: openstack-puppet-modules
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ivan Chavero
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 13:36 UTC by Gabriele Cerami
Modified: 2016-03-30 23:09 UTC (History)
3 users (show)

Fixed In Version: openstack-puppet-modules-2014.1-19.3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-30 23:09:42 UTC


Attachments (Terms of Use)
logs (1.87 MB, application/gzip)
2014-07-24 13:36 UTC, Gabriele Cerami
no flags Details

Description Gabriele Cerami 2014-07-24 13:36:56 UTC
Created attachment 920539 [details]
logs

Description of problem:

neutron/manifests/agents/ovs.pp creates /etc/sysconfig/network-scripts/ifcfg-br-{int,tun}. This seems to be problematic.
After installing openstack using astapor and foreman (without staypuft plugin), having those files created leads to a loop in which udev continuously adds and deletes the bridges, making it impossible to use them.
Removing ifcfg-br-* files stopped the loop, and bridge were correctly created
and usable
However, packstack installations seem not to be affected by this behaviour

Version-Release number of selected component (if applicable):

both production and stage repos are affected, creation in still present in source

Version     : 2014.1.1
Release     : 3.el6

Version     : 2014.1
Release     : 18.el6


How reproducible:
100%

Steps to Reproduce:
1. Install openstack with neutron using astapor and foreman
2. Soon after neutron-openvswitch-agent service in either networker or compute node is started, check /var/log/oepnvswitch/ovs-vswitchd.log
3. check udevadm monitor too

Actual results:

Endless loop in br-tun creation

Expected results:

br-tun correctly created

Additional info:

some logs attached. You can see things stabilizing at the end of logs, after removing ifcfg files.

Comment 2 Assaf Muller 2014-07-24 15:28:25 UTC
Additional info: There's no reason to persist IP information on either of those two bridges, and OVS persists the rest of the information. Thus, there's no reason at all to create ifcfg-br-tun or ifcfg-br-int.

The fix here is to make sure that Staypuft / Foreman, like Packstack, never create those files.

Comment 3 Gabriele Cerami 2014-07-29 17:06:08 UTC
The actual code that creates the bridge file is in 

vswitch/lib/puppet/provider/vs_port/ovs_redhat.rb line 61 (function create_bridge_file)

removing the function and any reference worked for me (no more loops)

Comment 4 Gabriele Cerami 2014-07-30 16:48:27 UTC
vswitch redhat provider is undergoing heavy rewriting - https://review.openstack.org/#/c/94504

bridge file creation was removed in the new version

Comment 5 Ivan Chavero 2014-07-30 18:18:22 UTC
This problem is fixed as a patch in the RHEL OSP openstack-puppet-modules RPM, i'm creating a version for RDO that includes this patches.


Note You need to log in before you can comment on or make changes to this bug.