Bug 112297 - Evolution still tries to lookup directory servers in disconnected mode
Summary: Evolution still tries to lookup directory servers in disconnected mode
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: evolution (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-17 11:13 UTC by Nick Strugnell
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-18 01:35:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nick Strugnell 2003-12-17 11:13:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
If an LDAP server is configured as a directory server, evolution tries
to use it to autocomplete email addresses in offline mode. This causes
a delay which hangs the entire UI until the lookup times out.

Looking at the Offline Folders tab in Settings, it appears that
Evolution automatically assumes that anything under 'Other Contacts'
is an offline-available folder.

LDAP contacts folders should be marked as unavailable in offline mode
as IMAP folders are.

Version-Release number of selected component (if applicable):
evolution-1.4.5-1

How reproducible:
Always

Steps to Reproduce:
1.Configure an LDAP server in evolution
2. Take machine off network
3. Go into offline mode (by clicking the connection icon in lower LH
corner)
4. Create a new e-mail and start typing a name in the 'To:' field
    

Actual Results:  UI hangs while LDAP connection is attempted and
eventually times out

Expected Results:  Name should be either resolved from local contacts
folder or unresolved

Additional info:

Could try running a local cacheing LDAP server on laptop and pointing
at  that as workaround

Comment 1 Dave Malcolm 2004-05-18 01:35:18 UTC
Looks like this is in upstream Bugzilla as
http://bugzilla.ximian.com/show_bug.cgi?id=35377


Note You need to log in before you can comment on or make changes to this bug.