Bug 1122978 - SMB:While running command user.cifs enable/disable there are error messages in log file for hook script.
Summary: SMB:While running command user.cifs enable/disable there are error messages i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: RHGS 3.0.3
Assignee: Meghana
QA Contact: surabhi
URL:
Whiteboard:
: 1131458 (view as bug list)
Depends On: 1125804
Blocks: 1162694
TreeView+ depends on / blocked
 
Reported: 2014-07-24 13:52 UTC by surabhi
Modified: 2015-05-13 17:42 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.6.0.33-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1125804 (view as bug list)
Environment:
Last Closed: 2015-01-15 13:38:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0038 normal SHIPPED_LIVE Red Hat Storage 3.0 enhancement and bug fix update #3 2015-01-15 18:35:28 UTC

Description surabhi 2014-07-24 13:52:53 UTC
Description of problem:
When user.cifs enable or user.cifs disable command is executed from the server for a volume there are error messages in log files related to nfs-ganesha hook script.



Version-Release number of selected component (if applicable):
glusterfs-geo-replication-3.6.0.25-1.el6rhs.x86_64
glusterfs-fuse-3.6.0.25-1.el6rhs.x86_64
glusterfs-rdma-3.6.0.25-1.el6rhs.x86_64
glusterfs-cli-3.6.0.25-1.el6rhs.x86_64
glusterfs-libs-3.6.0.25-1.el6rhs.x86_64
glusterfs-3.6.0.25-1.el6rhs.x86_64
glusterfs-devel-3.6.0.25-1.el6rhs.x86_64
glusterfs-server-3.6.0.25-1.el6rhs.x86_64
glusterfs-debuginfo-3.6.0.25-1.el6rhs.x86_64
samba-glusterfs-3.6.9-168.4.el6rhs.x86_64
glusterfs-api-3.6.0.25-1.el6rhs.x86_64
glusterfs-api-devel-3.6.0.25-1.el6rhs.x86_64

[2014-07-24 12:44:05.451062] E [run.c:190:runner_log] (-->/lib64/libpthread.so.0() [0x37254079d1] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(+0xcedb5) [0x7f196429edb5] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(glusterd_hooks_run_hooks+0x44c) [0x7f196429e9dc]))) 0-management: Failed to execute script: /var/lib/glusterd/hooks/1/set/post/S31ganesha-set.sh --volname=test -o user.cifs=enable
[2014-07-24 12:47:21.599440] I [run.c:190:runner_log] (-->/lib64/libpthread.so.0() [0x37254079d1] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(+0xcedb5) [0x7f196429edb5] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(glusterd_hooks_run_hooks+0x5a6) [0x7f196429eb36]))) 0-management: Ran script: /var/lib/glusterd/hooks/1/set/post/S30samba-set.sh --volname=test -o user.smb=enable
[2014-07-24 12:47:21.616416] E [run.c:190:runner_log] (-->/lib64/libpthread.so.0() [0x37254079d1] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(+0xcedb5) [0x7f196429edb5] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(glusterd_hooks_run_hooks+0x44c) [0x7f196429e9dc]))) 0-management: Failed to execute script: /var/lib/glusterd/hooks/1/set/post/S31ganesha-set.sh --volname=test -o user.smb=enable
[2014-07-24 12:49:14.852031] I [glusterd-handler.c:1377:__glusterd_handle_cli_get_volume] 0-glusterd: Received get vol req
[2014-07-24 12:49:38.208437] I [run.c:190:runner_log] (-->/lib64/libpthread.so.0() [0x37254079d1] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(+0xcedb5) [0x7f196429edb5] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(glusterd_hooks_run_hooks+0x5a6) [0x7f196429eb36]))) 0-management: Ran script: /var/lib/glusterd/hooks/1/set/post/S30samba-set.sh --volname=test -o user.smb=disable
[2014-07-24 12:49:38.233577] E [run.c:190:runner_log] (-->/lib64/libpthread.so.0() [0x37254079d1] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(+0xcedb5) [0x7f196429edb5] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(glusterd_hooks_run_hooks+0x44c) [0x7f196429e9dc]))) 0-management: Failed to execute script: /var/lib/glusterd/hooks/1/set/post/S31ganesha-set.sh --volname=test -o user.smb=disable
[2014-07-24 12:54:26.229095] I [glusterd-handler.c:1377:__glusterd_handle_cli_get_volume] 0-glusterd: Received get vol req
[2014-07-24 12:54:50.320552] I [run.c:190:runner_log] (-->/lib64/libpthread.so.0() [0x37254079d1] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(+0xcedb5) [0x7f196429edb5] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(glusterd_hooks_run_hooks+0x5a6) [0x7f196429eb36]))) 0-management: Ran script: /var/lib/glusterd/hooks/1/set/post/S30samba-set.sh --volname=test -o user.cifs=disable
[2014-07-24 12:54:50.346890] E [run.c:190:runner_log] (-->/lib64/libpthread.so.0() [0x37254079d1] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(+0xcedb5) [0x7f196429edb5] (-->/usr/lib64/glusterfs/3.6.0.25/xlator/mgmt/glusterd.so(glusterd_hooks_run_hooks+0x44c) [0x7f196429e9dc]))) 0-management: Failed to execute script: /var/lib/glusterd/hooks/1/set/post/S31ganesha-set.sh --volname=test -o user.cifs=disable

How reproducible:
Always

Steps to Reproduce:
1.create a volume
2.gluster volume set vol-name user.cifs enable/disable
3.or run gluster vol set vol-name user.smb enable/disable

Actual results:
errors in logs as it tries to execute ganesha hook script.

Expected results:
the user.cifs enable/disable setting should not cause any error in logs w.r.t.ga
nesha hook scripts.

Additional info:

Comment 2 Meghana 2014-07-25 07:25:31 UTC
As suspected, when I run gluster vol set testvol nfs-ganesha.host enable on,

I see the following samba related errors in the logs,
[2014-07-24 12:12:49.927187] E [run.c:190:runner_log] (-->/lib64/libpthread.so.0() [0x3481e07851] (-->/usr/lib/glusterfs/3.7dev/xlator/mgmt/glusterd.so(+0xc9db5) [0x7fca215f2db5] (-->/usr/lib/glusterfs/3.7dev/xlator/mgmt/glusterd.so(glusterd_hooks_run_hooks+0x44c) [0x7fca215f29dc]))) 0-management: Failed to execute script: /var/lib/glusterd/hooks/1/set/post/S30samba-set.sh --volname=testvol -o nfs-ganesha.host=10.70.43.78
[2014-07-24 12:12:49.983760] E [run.c:190:runner_log] (-->/lib64/libpthread.so.0() [0x3481e07851] (-->/usr/lib/glusterfs/3.7dev/xlator/mgmt/glusterd.so(+0xc9db5) [0x7fca215f2db5] (-->/usr/lib/glusterfs/3.7dev/xlator/mgmt/glusterd.so(glusterd_hooks_run_hooks+0x44c) [0x7fca215f29dc]))) 0-management: Failed to execute script: /var/lib/glusterd/hooks/1/set/post/S31ganesha-set.sh --volname=testvol -o nfs-ganesha.host=10.70.43.78
[2014-07-24 12:12:50.065805] W [socket.c:530:__socket_rwv] 0-management: readv on /var/run/b8fced70f04a9f1b3c9a7e48d0678055.socket failed (Invalid argument)

Both the scripts will be run invariably when a volume set is executed. The status i.e, success/failure of BOTH the scripts will be reported when any volume set is executed.
 
For example,
gluster vol set testvol nfs.disable on,

I see the same logs,

[2014-07-24 12:19:42.870425] E [run.c:190:runner_log] (-->/lib64/libpthread.so.0() [0x3481e07851] (-->/usr/lib/glusterfs/3.7dev/xlator/mgmt/glusterd.so(+0xc9db5) [0x7fca215f2db5] (-->/usr/lib/glusterfs/3.7dev/xlator/mgmt/glusterd.so(glusterd_hooks_run_hooks+0x44c) [0x7fca215f29dc]))) 0-management: Failed to execute script: /var/lib/glusterd/hooks/1/set/post/S30samba-set.sh --volname=testvol -o nfs.disable=on
[2014-07-24 12:19:42.882974] I [run.c:190:runner_log] (-->/lib64/libpthread.so.0() [0x3481e07851] (-->/usr/lib/glusterfs/3.7dev/xlator/mgmt/glusterd.so(+0xc9db5) [0x7fca215f2db5] (-->/usr/lib/glusterfs/3.7dev/xlator/mgmt/glusterd.so(glusterd_hooks_run_hooks+0x5a6) [0x7fca215f2b36]))) 0-management: Ran script: /var/lib/glusterd/hooks/1/set/post/S31ganesha-set.sh --volname=testvol -o nfs.disable=on

I'm not sure if the behaviour itself is a bug. I need to check if S31ganesha-set.sh exits with the right value when the key is not nfs-ganesha.enable/nfs-ganesha.host. I'll do that.

Comment 3 Meghana 2014-08-25 09:35:39 UTC
*** Bug 1131458 has been marked as a duplicate of this bug. ***

Comment 5 surabhi 2014-11-24 15:50:17 UTC
With the fix , when any volume set operation is executed there are no errors in logs seen from ganesha hook script.
Verified with cifs.enable and disable options.Also verified with any volume set operations.
I [run.c:190:runner_log] (-->/lib64/libpthread.so.0() [0x35bbc079d1] (-->/usr/lib64/glusterfs/3.6.0.33/xlator/mgmt/glusterd.so(+0xd1ee5) [0x7f031a147ee5] (-->/usr/lib64/glusterfs/3.6.0.33/xlator/mgmt/glusterd.so(glusterd_hooks_run_hooks+0x5a6) [0x7f031a147c66]))) 0-management: Ran script: /var/lib/glusterd/hooks/1/set/post/S30samba-set.sh --volname=verify-vol -o user.cifs=enable
I [run.c:190:runner_log] (-->/lib64/libpthread.so.0() [0x35bbc079d1] (-->/usr/lib64/glusterfs/3.6.0.33/xlator/mgmt/glusterd.so(+0xd1ee5) [0x7f031a147ee5] (-->/usr/lib64/glusterfs/3.6.0.33/xlator/mgmt/glusterd.so(glusterd_hooks_run_hooks+0x5a6) [0x7f031a147c66]))) 0-management: Ran script: /var/lib/glusterd/hooks/1/set/post/S31ganesha-set.sh --volname=verify-vol -o user.cifs=enable

Moving the Bug to verified with version :
samba-glusterfs-3.6.509-169.1.el6rhs.x86_64
glusterfs-fuse-3.6.0.33-1.el6rhs.x86_64
glusterfs-3.6.0.33-1.el6rhs.x86_64
glusterfs-server-3.6.0.33-1.el6rhs.x86_64
glusterfs-rdma-3.6.0.33-1.el6rhs.x86_64
glusterfs-api-3.6.0.33-1.el6rhs.x86_64
glusterfs-cli-3.6.0.33-1.el6rhs.x86_64
glusterfs-geo-replication-3.6.0.33-1.el6rhs.x86_64
glusterfs-libs-3.6.0.33-1.el6rhs.x86_64

Comment 7 errata-xmlrpc 2015-01-15 13:38:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0038.html


Note You need to log in before you can comment on or make changes to this bug.