Bug 112299 - fc2-dev -- IDE LBA disks not detected correctly
fc2-dev -- IDE LBA disks not detected correctly
Status: CLOSED DUPLICATE of bug 115980
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-17 08:43 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2003-12-17 08:43:28 EST
Description of problem:
Downloaded and attempted to install fc-development.  I had previously
installed both RHL9 and FC1 on these system. Both systems are dual
processor.  The P-II has a WDC 6.4GB drive and a WDC 18GB drive.  The
P-III has two Maxtor 60GB drives and a Maxtor 80GB drive.

The install is an NFS install booting from cdrom created from boot.iso.

I have the BIOS configured on both systems for IDE LBA.

On the P-III system, I have most partitions pre-allocated.  When I
went to install, I got a popup for hda and hdb (two 60GB drives)
saying the BIOS values were not correct and should reboot with
hda=7476,255,63

For the P-II, I only have hda1 and swap defined on hda.  When I went
to install, I again got a popup saying that the detected values of
13328,15,63 was not correct and that I should reboot with hda=784,255,63.

If I switch to VT-2 and ran fdisk, it displayed the proper (LBA) values.

Version-Release number of selected component (if applicable):
FC2-development as of 12/15/03

How reproducible:
Every system with IDE disks
Comment 1 Gene Czarcinski 2003-12-17 10:38:43 EST
Mmmm ... parted seemed to be the same one which is in FC1 so I did not
believe it was the problem.

But then again, maybe it is something in the kernel which changed and
parted still works the "old way" and is not responsive to the change.

It appears to me that parted does not look at the partition table
actually on the disk since fdisk reports the correct (LBA) values.

It is interesting that when I used the hda=784,255,63 paremter at boot
time and actually installed the system, when I booted the actual
system, it looked OK.
Comment 2 Jeremy Katz 2003-12-17 10:49:56 EST
The kernel used to actually do more dark voodoo determination and then
export those values to userspace.  Now it doesn't, instead requiring
every user space program to do so instead :(
Comment 3 Jeremy Katz 2004-06-25 15:33:36 EDT

*** This bug has been marked as a duplicate of 115980 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:00:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.