Bug 1123004 - Automounter maps with 'localdir -fstype=glusterfs host:/remote/dir' fails
Summary: Automounter maps with 'localdir -fstype=glusterfs host:/remote/dir' fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: fuse
Version: pre-release
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Anders Blomdell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1171259
TreeView+ depends on / blocked
 
Reported: 2014-07-24 15:09 UTC by Anders Blomdell
Modified: 2015-05-14 17:42 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:26:49 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Anders Blomdell 2014-07-24 15:09:55 UTC
Description of problem:

It's not possible to directly use 
  
  localdir -fstype=glusterfs host:/remote/dir

in linux automounter maps since automounter will translate this to
 
  /sbin/mount.glusterfs host:/remote/dir /localdir -n -o rw

and -n is not handled by /sbin/mount.glusterfs.

Comment 1 Anand Avati 2014-07-24 15:31:42 UTC
REVIEW: http://review.gluster.org/8373 (Allow gluster to be used with linux automounter) posted (#1) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 2 Anand Avati 2014-07-27 20:37:42 UTC
COMMIT: http://review.gluster.org/8373 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit f8496dab2f6111bdc5ced0881d15061160b76e52
Author: Anders Blomdell <anders.blomdell@control.lth.se>
Date:   Thu Jul 24 16:55:45 2014 +0200

    Allow gluster to be used with linux automounter
    
    Added (ignored) -n option to mount.glusterfs command
    
    Change-Id: I9209da215d38507cd9d01b1e9af4aecff4414f83
    BUG: 1123004
    Signed-off-by: Anders Blomdell <anders.blomdell@control.lth.se>
    Reviewed-on: http://review.gluster.org/8373
    Reviewed-by: Harshavardhana <harsha@harshavardhana.net>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 3 Niels de Vos 2014-07-30 07:47:19 UTC
Nice!

For reference, this is how I use autofs:
- http://blog.nixpanic.net/2014/04/configuring-autofs-for-glusterfs-35.html

Comment 4 Niels de Vos 2015-05-14 17:26:49 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:35:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:37:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:42:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.