Bug 1123015 - Satellite timeout takes me to a deprecated api output page
Summary: Satellite timeout takes me to a deprecated api output page
Keywords:
Status: CLOSED DUPLICATE of bug 1118444
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 15:40 UTC by sthirugn@redhat.com
Modified: 2014-07-24 15:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-24 15:47:03 UTC


Attachments (Terms of Use)
api output shown in UI (350.50 KB, image/png)
2014-07-24 15:41 UTC, sthirugn@redhat.com
no flags Details

Description sthirugn@redhat.com 2014-07-24 15:40:31 UTC
Description of problem:
Satellite timeout takes me to a deprecated api output page

Version-Release number of selected component (if applicable):
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.29-1.el6sat.noarch
* foreman-compute-1.6.0.29-1.el6sat.noarch
* foreman-gce-1.6.0.29-1.el6sat.noarch
* foreman-libvirt-1.6.0.29-1.el6sat.noarch
* foreman-ovirt-1.6.0.29-1.el6sat.noarch
* foreman-postgresql-1.6.0.29-1.el6sat.noarch
* foreman-proxy-1.6.0.21-1.el6sat.noarch
* foreman-selinux-1.6.0-8.el6sat.noarch
* foreman-vmware-1.6.0.29-1.el6sat.noarch
* katello-1.5.0-27.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.56-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Content Hosts page.
2. Leave the system idle for few minutes (30?) for timeout
3. After the timeout time, clicking on any of the item in UI takes me to the login page
4. After entering the credentials it takes me to a deprecated api output page:
https://sat6host.redhat.com/katello/api/v2/systems?organization_id=3&page=1&search=&sort_by=name&sort_order=ASC

Actual results:
As explained in step 4 above

Expected results:
I should be navigated back to my satellite6 UI and not an api output page

Additional info:

Comment 1 sthirugn@redhat.com 2014-07-24 15:41:00 UTC
Created attachment 920599 [details]
api output shown in UI

Comment 3 Brad Buckingham 2014-07-24 15:47:03 UTC

*** This bug has been marked as a duplicate of bug 1118444 ***


Note You need to log in before you can comment on or make changes to this bug.