Bug 1123047 - cannot run pkcsslotd
Summary: cannot run pkcsslotd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 17:27 UTC by Petr Lautrbach
Modified: 2015-03-10 02:59 UTC (History)
4 users (show)

Fixed In Version: selinux-policy-3.13.1-116.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-10 02:59:26 UTC


Attachments (Terms of Use)
AVCs (5.84 KB, text/plain)
2014-07-24 17:27 UTC, Petr Lautrbach
no flags Details

Description Petr Lautrbach 2014-07-24 17:27:02 UTC
Created attachment 920648 [details]
AVCs

Description of problem:
# systemctl start pkcsslotd
Job for pkcsslotd.service failed. See 'systemctl status pkcsslotd.service' and 'journalctl -xn' for details.


Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-64.fc22.noarch

How reproducible:
always

Proposed fix https://github.com/selinux-policy/selinux-policy/pull/2

Comment 1 Lukas Vrabec 2014-07-24 18:14:03 UTC
Hi Petr, 

I wrote some changes for your patch in github. You can change it or I'll do it, let me know.

Comment 2 Miroslav Grepl 2014-07-25 05:51:54 UTC
We have a discussion on github.

Comment 3 Lukas Vrabec 2014-07-25 13:19:12 UTC
commit e14c5e412b95ff1ddc82d37c8dd2a0173cd8ac26
Merge: 5251342 91dd88c
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Fri Jul 25 15:17:21 2014 +0200

    Merge pull request #2 from bachradsusi/rawhide-contrib-pkcs_slot_d
    
    Allow pkcs_slotd_t read /etc/passwd, Label /var/lock/opencryptoki as pkcs_slotd_lock_t (#1123047)

https://github.com/bachradsusi/selinux-policy/commit/91dd88c70f7d00d042fcc152aa1e560d1779fef5

Comment 4 Lukas Vrabec 2014-07-25 13:21:58 UTC
commit 632901b5da55ad9480156c68486a5bfc82356073
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Fri Jul 25 15:20:46 2014 +0200

    Fix typo in pkcs.if

Comment 5 Jaroslav Reznik 2015-03-03 17:15:05 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 6 Fedora Update System 2015-03-06 22:09:15 UTC
selinux-policy-3.13.1-116.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/selinux-policy-3.13.1-116.fc22

Comment 7 Fedora Update System 2015-03-09 08:38:11 UTC
Package selinux-policy-3.13.1-116.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.13.1-116.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-3508/selinux-policy-3.13.1-116.fc22
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-03-10 02:59:26 UTC
selinux-policy-3.13.1-116.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.