Bug 1123067 - User is not informed, nor is there a way to check if completed, the quota xattr cleanup after disabling quota
Summary: User is not informed, nor is there a way to check if completed, the quota xat...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.5.2
Hardware: All
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Manikandan
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 18:40 UTC by Joe Julian
Modified: 2016-09-20 04:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-20 08:30:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Joe Julian 2014-07-24 18:40:27 UTC
http://review.gluster.org/6369/ introduced an automatic cleanup of quota xattrs. If the user disables quota and immediately re-enables quota, inconsistent things seem to happen, including differences between df and du and brick crashes.

I suspect this is due to the cleanup script having not yet completed. Since the user was unaware of the script's existence, he did not anticipate any problems.

At the very least, a notice should be displayed from the CLI when quota is disabled telling the user what to look for to determine if the cleanup has finished.

Comment 1 Vijaikumar Mallikarjuna 2015-01-22 08:29:26 UTC
One solution we can think of is to maintain version for quota-xattrs, with this we can enable/disable quota, while the cleanup script is still running.

Comment 2 Vijaikumar Mallikarjuna 2015-12-21 09:12:06 UTC
Hi Joe,

This issue has been fixed in 3.7 with versioning the xattrs.

Comment 3 Vijaikumar Mallikarjuna 2016-04-20 08:30:45 UTC
As per comment# 2, problem of quota accounting inconsistency with disabling and enabling quota is solved with quota-xattr versioning feature introduced in 3.7.
Also there is no plan for back-porting this feature to 3.5, so closing this bug


Note You need to log in before you can comment on or make changes to this bug.